Nabble has removed Mailing-list integration.
Posts created here DO NOT GET SENT TO THE MAILING LIST.
Mailing-list emails DO NOT GET POSTED TO THE FORUM.
So basically the Forum is now out of date, we are looking into migrating the history.

For now you should send emails, people will see them, discuss@lists.openscad.org.

another 'newbe' question

classic Classic list List threaded Threaded
4 messages Options
dpa
Reply | Threaded
Open this post in threaded view
|

another 'newbe' question

dpa
Sorry for asking this simple question, but whenever I used something from the Library folder it never worked and I ended up by copying all I needed into the same folder or into my scad file directly to get it to work.

Now, in order to get the threadlib to work I checked once again. I tried to show something from "list-comprehension-demos" what uses scad-utils. I have 'scad-utils' installed (to confirm, I opened this folder safely through OpenSCAD's menu 'File/Show Library Folder...') and it's all there. But the opened scad doesn't find it.

I made this little movie to show the problem.
Can someone tell me what is the problem here?


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: another 'newbe' question

MichaelAtOz
Administrator
dpa wrote

> Sorry for asking this simple question, but whenever I used something from
> the Library folder it never worked and I ended up by copying all I needed
> into the same folder or into my scad file directly to get it to work.
>
> Now, in order to get the threadlib to work I checked once again. I tried
> to
> show something from "list-comprehension-demos" what uses scad-utils. I
> have
> 'scad-utils' installed (to confirm, I opened this folder safely through
> OpenSCAD's menu 'File/Show Library Folder...') and it's all there. But the
> opened scad doesn't find it.
>
> I made this little movie
> <https://photos.app.goo.gl/cDG1JFZ2RpgnwKUU8> to
> show the problem.
> Can someone tell me what is the problem here?
>
> _______________________________________________
> OpenSCAD mailing list

> Discuss@.openscad

> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

Sorry, nothing comes to mind. You could check the paths in
Help/show-library-info, but as it is opening that path it must be
there.Maybe some clue here
https://en.wikibooks.org/wiki/OpenSCAD_User_Manual/Libraries



-----
Admin - email* me if you need anything,  or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
OpenSCAD Admin - email* me if you need anything, or if I've done something stupid...
* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain;
to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.
tp3
Reply | Threaded
Open this post in threaded view
|

Re: another 'newbe' question

tp3
Why is there a cloud icon behind the file? Is that some
kind of remote folder and the file is not actually there?

ciao,
  Torsten.


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
dpa
Reply | Threaded
Open this post in threaded view
|

Re: another 'newbe' question

dpa
Am Fr., 12. Juni 2020 um 01:28 Uhr schrieb Torsten Paul <[hidden email]>:
Why is there a cloud icon behind the file? Is that some
kind of remote folder and the file is not actually there?

Yes! In fact this was the reason! 
I use iCloud for Documents (I think this is standard) where OpenScad/libraries is part of. Everything 'is there' but (showing the cloud-) only on demand. When OpenSCAD asks for anything it doesn't download it (what I would expect from a smart iCloud/finder) so it keeps unknown. Now I downloaded everything and it works!
 
ciao,
  Torsten.
 
Thank you for your open eyes, Torsten! 

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org