$vpr not set in command line mode

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

$vpr not set in command line mode

nophead
I made some text face the camera with rotate($vpr) but it only works in the GUI. $vpr seems to be [0, 0, 0] when run from the command line. Any reason why this shouldn't be set from the camera in command line mode?

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: $vpr not set in command line mode

MichaelAtOz
Administrator
Sounds like a bug to me.



-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
tp3
Reply | Threaded
Open this post in threaded view
|

Re: $vpr not set in command line mode

tp3
On 26.05.19 01:05, MichaelAtOz wrote:
> Sounds like a bug to me.

It's not a bug, it simply was never intended to be
used in command line mode. In addition there were ways
to define the camera position on command line which did
not easily translate into those variables.

That might have changed now with the camera code updates.
So if we can calculate the values for all combinations
that are possible via command line, it makes sense to
add that feature.

ciao,
  Torsten.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten