uni-build-dependencies.sh failing

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

uni-build-dependencies.sh failing

NathanA
I'm trying to use uni-build-dependencies.sh but it is failing. Output is:

BASEDIR: /home/ec2-user/openscad_deps
DEPLOYDIR: /home/ec2-user/openscad_deps
PATH modified
LD_LIBRARY_PATH modified
LD_RUN_PATH modified
OPENSCAD_LIBRARIES modified
GLEWDIR modified
Please re-run qmake and run 'make clean' if necessary
Note: The NUMCPU environment variable can be set for parallel builds
Using basedir: /home/ec2-user/openscad_deps
Using deploydir: /home/ec2-user/openscad_deps
Using srcdir: /home/ec2-user/openscad_deps/src
Number of CPUs for parallel builds: 1
Building cmake 2.8.8 ...

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: uni-build-dependencies.sh failing

OleV
Probably because the cmake archive did not get fetched properly. Check if the file ~/openscad_deps/src/cmake-2.8.8.tar.gz contains just a short notice that the link has moved. If so, edit the uni-build-depencies.sh, where it fetches cmake to
  curl -O https://cmake.org/files/v2.8/cmake-$version.tar.gz
then, remove the (invalid) ~/openscad_deps/src/cmake-2.8.8.tar.gz file and run the script again
Or you can manually download cmake-2.8.8.tar.gz from cmake.org, place the file in  ~/openscad_deps/src/ and rerun the script without editing.
Loading...