openscad bug / problem kubuntu 18.04

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

openscad bug / problem kubuntu 18.04

sasa





> openscad

// gui runs but as soon as any file is selected this happens

QOpenGLWidget: Failed to create context
QOpenGLWidget: Failed to create context
QXcbConnection: XCB error: 3 (BadWindow), sequence: 1085, resource id:
31461207, major code: 40 (TranslateCoords), minor code: 0
composeAndFlush: makeCurrent() failed
composeAndFlush: makeCurrent() failed
..

It looks like no window ever opens but... a frame is drawn and never painted
(so the canvas is a distorted frozen version of the background). when the
mosue moves over this frame "composeAndFlush: makeCurrent() failed" is
continually repeated.


Any clue as to what is happening here? or to a working solution?



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: openscad bug / problem kubuntu 18.04

sasa

I've built the latest git version from source and I've got the same problem!



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: openscad bug / problem kubuntu 18.04

sasa

Tried this as well:

  # gdebi will manage .deb dependencies
    sudo apt-get install gdebi-core
    wget http://ftp.us.debian.org/debian/pool/main/o/openscad/
openscad_2015.03-2+dfsg-2+b3_amd64.deb
    sudo gdebi openscad_2015.03-2+dfsg-2+b3_amd64.deb

Same problem

So...if any of these are working for anyone else on ubuntu / kubunut 18.04 I'd
be interested - I simply don't know how to proceed with fixing this problem.









On Saturday, 13 October 2018 21:09:38 BST sasa wrote:

> I've built the latest git version from source and I've got the same problem!
>
>
>
> --
> Sent from: http://forum.openscad.org/
>
> _______________________________________________
> OpenSCAD mailing list
> [hidden email]
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org





_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
tp3
Reply | Threaded
Open this post in threaded view
|

Re: openscad bug / problem kubuntu 18.04

tp3
On 10/13/2018 10:24 PM, [hidden email] wrote:
> So...if any of these are working for anyone else on ubuntu /
> kubunut 18.04 I'd be interested - I simply don't know how to
> proceed with fixing this problem.
>
I just built on a fresh kubuntu 18.04.1 VM and there's no problem.

Are you using some special graphics driver, like the NVIDIA blob?
Maybe try:

   __GL_THREADED_OPTIMIZATIONS=0 openscad

See https://github.com/openscad/openscad/issues/1848 for more info
on that.

ciao,
   Torsten.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: openscad bug / problem kubuntu 18.04

sasa

Ok tried https://github.com/openscad/openscad/issues/1848

__GL_THREADED_OPTIMIZATIONS=0 openscad

and

LIBGL_ALWAYS_SOFTWARE=1 openscad

Both made no difference :(

I do have the nvidia driver loaded - I could try removing this for debug but I
guess LIBGL_ALWAYS_SOFTWARE=1 openscad covers that test already?



On Saturday, 13 October 2018 23:40:09 BST Torsten Paul wrote:

> On 10/13/2018 10:24 PM, [hidden email] wrote:
> > So...if any of these are working for anyone else on ubuntu /
> > kubunut 18.04 I'd be interested - I simply don't know how to
> > proceed with fixing this problem.
>
> I just built on a fresh kubuntu 18.04.1 VM and there's no problem.
>
> Are you using some special graphics driver, like the NVIDIA blob?
> Maybe try:
>
>    __GL_THREADED_OPTIMIZATIONS=0 openscad
>
> See https://github.com/openscad/openscad/issues/1848 for more info
> on that.
>
> ciao,
>    Torsten.
>
> _______________________________________________
> OpenSCAD mailing list
> [hidden email]
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org





_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
tp3
Reply | Threaded
Open this post in threaded view
|

Re: openscad bug / problem kubuntu 18.04

tp3
On 10/14/2018 01:52 AM, [hidden email] wrote:
> I do have the nvidia driver loaded - I could try removing
> this for debug but I guess LIBGL_ALWAYS_SOFTWARE=1 openscad
> covers that test already?
>
It should, yes. But as it's currently unclear what's causing
the issue and it's not reproducible on a fresh install, it
might still be worth a try.

ciao,
   Torsten.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: openscad bug / problem kubuntu 18.04

sasa


Problem solved:

I don't know what the problem was but I started to get other related problems
with other software and got to thinking I'd had >60days uptime so rebooted and
now openscad (and the other stuff) has started working. My guess is a leak /
bug in nvidia or plasma is responsible. Given the length of time to manifest
itself I suspect debugging is practically impossible...

Thanks folks!





On Sunday, 14 October 2018 01:56:29 BST Torsten Paul wrote:

> On 10/14/2018 01:52 AM, [hidden email] wrote:
> > I do have the nvidia driver loaded - I could try removing
> > this for debug but I guess LIBGL_ALWAYS_SOFTWARE=1 openscad
> > covers that test already?
>
> It should, yes. But as it's currently unclear what's causing
> the issue and it's not reproducible on a fresh install, it
> might still be worth a try.
>
> ciao,
>    Torsten.
>
> _______________________________________________
> OpenSCAD mailing list
> [hidden email]
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org





_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org