kit wallace files are compiling wrong

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

kit wallace files are compiling wrong

ufomorace
http://kitwallace.co.uk/3d/solid-to-scad.xq?id=SmallStellatedDodecahedron&scad=wire

These pages probably worked originally, is there a change from an abolished code syntax error?
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

runsun
If you are talking about the "DEPRECATED: The assign() module ... " warning, then modify each assign in the following code
      if (...)
        assign (f = xxx)
        ...;
to
      if (...) {
        f = xxx ;
        ...;
     }
$ Runsun Pan, PhD
$ libs: scadx, doctest, faces(git), offline doc(git), runscad.py(2,git), editor of choice: CudaText ( OpenSCAD lexer); $ Tips; $ Snippets
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

ufomorace
Thanks runsun, i will attempt that. cool libs runsun, if i was not confused at this moment i would have a change to figure them out in the near future. !!! nice!!! The kit wallace codes are very sound i hope i will have them to make some fish and chips in 3d for my city coding project.
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

runsun
You are welcome ! KitWallace is one of the several light houses of mine learning Openscad. Glad you find the same way.
$ Runsun Pan, PhD
$ libs: scadx, doctest, faces(git), offline doc(git), runscad.py(2,git), editor of choice: CudaText ( OpenSCAD lexer); $ Tips; $ Snippets
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

kitwallace
Very chuffed that you both find my stuff helpful.  

I've updated the polyhedral code to remove assign.  That Small Stellated  Dodecahedron looks horrible!  I've a new version which works on polyhedral forms in user space without CSG operations and supports Conway operations that I'll put up RSN.

runsun,  I'm looking forward to your new libraries so I can do even more on polyhedra, particularly to see if I can do crystal stuff using Miller indexes in user space

Kit
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

runsun
Just checked info about Miller Index. Cool thing. A very good way to describe plane, which could be very useful.

One item on my to-do list is to build a chemistry.scad lib. In fact, it's already easy for my lib to generate, for example, a benzene molecule --- the first 3 lines to generate points, the next 2 to display:



which is made with 5 lines of code:
   pqr=pqr();    
   pts = circlePts( pqr, n=6,rad=3);
   ringPts = circlePts( pqr, n=48,rad=1.8);
   
   MarkPts( pts, ["r=0.5;color=black", "chain",["closed",true,"nside",24,"color",undef,"r",0.2] ] );
   MarkPts( ringPts, ["ball=0", "chain",["closed",true,"nside",24,"color",undef,"r",0.2] ] );
I can picture this to be a very good tool for chemistry education. Lets talk more about the Miller Index once my lib is ready.
$ Runsun Pan, PhD
$ libs: scadx, doctest, faces(git), offline doc(git), runscad.py(2,git), editor of choice: CudaText ( OpenSCAD lexer); $ Tips; $ Snippets
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

ufomorace
In reply to this post by kitwallace
Kit that page is legendary, makes me want to put all the files in a game engine and play geometric billiards and make some viewing environments for them. cool.
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

ufomorace
This page with a conway operator in openscad is crashing the program totally when running a preview mesh, openscad runs and echos some values and then the program is closed by windows.

https://github.com/KitWallace/openscad/blob/master/conway.scad
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

kitwallace
That's odd, it works fine for me, rendering a solid-edge (shell) tetrahedron.  ( on openSCAD version 2015-06-14 on a Windows 7 machine.)

On Sun, Sep 27, 2015 at 12:56 PM, ufomorace [via OpenSCAD] <[hidden email]> wrote:
This page with a conway operator in openscad is crashing the program totally when running a preview mesh, openscad runs and echos some values and then the program is closed by windows.

https://github.com/KitWallace/openscad/blob/master/conway.scad


If you reply to this email, your message will be added to the discussion below:
http://forum.openscad.org/kit-wallace-files-are-compiling-wrong-tp13897p14015.html
To unsubscribe from kit wallace files are compiling wrong, click here.
NAML

tp3
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

tp3
On 09/27/2015 05:56 PM, kitwallace wrote:
> That's odd, it works fine for me, rendering a solid-edge (shell)
> tetrahedron.  ( on openSCAD version 2015-06-14 on a Windows 7 machine.)
>
Looks like it triggers a bug that was fixed after the release. It
crashes with 2015.03-1 but works fine with the latest dev version.

ciao,
  Torsten.


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

kitwallace
Must have been a bug which flew in and out again without me noticing since it works in 2014.11.09 !

On Sun, Sep 27, 2015 at 5:08 PM, tp3 [via OpenSCAD] <[hidden email]> wrote:
On 09/27/2015 05:56 PM, kitwallace wrote:
> That's odd, it works fine for me, rendering a solid-edge (shell)
> tetrahedron.  ( on openSCAD version 2015-06-14 on a Windows 7 machine.)
>
Looks like it triggers a bug that was fixed after the release. It
crashes with 2015.03-1 but works fine with the latest dev version.

ciao,
  Torsten.


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten



If you reply to this email, your message will be added to the discussion below:
http://forum.openscad.org/kit-wallace-files-are-compiling-wrong-tp13897p14017.html
To unsubscribe from kit wallace files are compiling wrong, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

comprehensible
Hi i am finding an error on this page:
http://kitwallace.co.uk/3d/solid-index.xq?mode=solid&id=HeptagonalDodecahedronB1

The # Sides option in wiremesh stays the same regardless of the figure used.

Kindest Regards
Reply | Threaded
Open this post in threaded view
|

Re: kit wallace files are compiling wrong

kitwallace
Hey thanks for finding that bug -  as you say, # sides was ignored - I've just fixed it.

Chris



On Tue, Dec 27, 2016 at 8:05 PM, comprehensible [via OpenSCAD] <[hidden email]> wrote:
Hi i am finding an error on this page:
http://kitwallace.co.uk/3d/solid-index.xq?mode=solid&id=HeptagonalDodecahedronB1

The # Sides option in wiremesh stays the same regardless of the figure used.

Kindest Regards


If you reply to this email, your message will be added to the discussion below:
http://forum.openscad.org/kit-wallace-files-are-compiling-wrong-tp13897p19787.html
To unsubscribe from kit wallace files are compiling wrong, click here.
NAML