installation errors on ubuntu

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

installation errors on ubuntu

M.Rule
I downloaded th x64 precompiled binaries, extracted them, and ran the
install script. When I try to run openscad, I get this error :

/usr/local/bin/../lib/openscad//openscad: /usr/lib/libstdc++.so.6:
version `GLIBCXX_3.4.14' not found (required by
/usr/local/bin/../lib/openscad//openscad)

I'm not sure how to fix this.
--mrule.

Reply | Threaded
Open this post in threaded view
|

Re: installation errors on ubuntu

M.Rule
Is there something off with my email settings, or has no-one replied to this yet?

On Mon, Sep 19, 2011 at 11:29 AM, M.Rule <[hidden email]> wrote:
I downloaded th x64 precompiled binaries, extracted them, and ran the
install script. When I try to run openscad, I get this error :

/usr/local/bin/../lib/openscad//openscad: /usr/lib/libstdc++.so.6:
version `GLIBCXX_3.4.14' not found (required by
/usr/local/bin/../lib/openscad//openscad)

I'm not sure how to fix this.
--mrule.

Reply | Threaded
Open this post in threaded view
|

Re: installation errors on ubuntu

Giles Bathgate-2
I think the problem is that the version of libstdc++.so.6 that the
precompiled version of openscad was built against is not the same
version as is on your system.

You will either have to get the right version, or compile openscad
yourself (which isn't that hard)

http://en.wikibooks.org/wiki/OpenSCAD_User_Manual/Building_on_Linux/UNIX

Regards

Giles

 On Mon, Sep 19, 2011 at 11:29 AM, M.Rule <[hidden email]> wrote:

>
> I downloaded th x64 precompiled binaries, extracted them, and ran the
> install script. When I try to run openscad, I get this error :
>
> /usr/local/bin/../lib/openscad//openscad: /usr/lib/libstdc++.so.6:
> version `GLIBCXX_3.4.14' not found (required by
> /usr/local/bin/../lib/openscad//openscad)
>
> I'm not sure how to fix this.
> --mrule.

Reply | Threaded
Open this post in threaded view
|

Re: installation errors on ubuntu

M.Rule
thanks, that makes sense. I'll let you know if it works.

On Tue, Sep 20, 2011 at 6:13 PM, Giles Bathgate <[hidden email]> wrote:
I think the problem is that the version of libstdc++.so.6 that the
precompiled version of openscad was built against is not the same
version as is on your system.

You will either have to get the right version, or compile openscad
yourself (which isn't that hard)

http://en.wikibooks.org/wiki/OpenSCAD_User_Manual/Building_on_Linux/UNIX

Regards

Giles

 On Mon, Sep 19, 2011 at 11:29 AM, M.Rule <[hidden email]> wrote:
>
> I downloaded th x64 precompiled binaries, extracted them, and ran the
> install script. When I try to run openscad, I get this error :
>
> /usr/local/bin/../lib/openscad//openscad: /usr/lib/libstdc++.so.6:
> version `GLIBCXX_3.4.14' not found (required by
> /usr/local/bin/../lib/openscad//openscad)
>
> I'm not sure how to fix this.
> --mrule.
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://rocklinux.net/mailman/listinfo/openscad

Reply | Threaded
Open this post in threaded view
|

Re: installation errors on ubuntu

M.Rule
excellent, building from scratch worked and, thanks to that wiki, was almost completely painless. good job. thank you.

On Tue, Sep 20, 2011 at 6:16 PM, M.Rule <[hidden email]> wrote:
thanks, that makes sense. I'll let you know if it works.


On Tue, Sep 20, 2011 at 6:13 PM, Giles Bathgate <[hidden email]> wrote:
I think the problem is that the version of libstdc++.so.6 that the
precompiled version of openscad was built against is not the same
version as is on your system.

You will either have to get the right version, or compile openscad
yourself (which isn't that hard)

http://en.wikibooks.org/wiki/OpenSCAD_User_Manual/Building_on_Linux/UNIX

Regards

Giles

 On Mon, Sep 19, 2011 at 11:29 AM, M.Rule <[hidden email]> wrote:
>
> I downloaded th x64 precompiled binaries, extracted them, and ran the
> install script. When I try to run openscad, I get this error :
>
> /usr/local/bin/../lib/openscad//openscad: /usr/lib/libstdc++.so.6:
> version `GLIBCXX_3.4.14' not found (required by
> /usr/local/bin/../lib/openscad//openscad)
>
> I'm not sure how to fix this.
> --mrule.
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://rocklinux.net/mailman/listinfo/openscad