gui doesn't work in new version

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

gui doesn't work in new version

Leef_me
This post has NOT been accepted by the mailing list yet.

I had previously installed this version and the gui interface worked.
OpenSCAD-2014.03-x86-32-Installer.exe


I uninstalled the above and installed this version but the gui interface does not work.
OpenSCAD-2015.03-x86-32-Installer.exe

While searching the forum for an answer, I found this thread:
   http://forum.openscad.org/2015-3-crash-td12110.html#a12127
       in the thread Marius wrote, "I suspect that your GPU drivers are old"


I tried updating my video drivers, but I still don't see the gui (btw, I use USB->video adapters)

I don't know how to use the "Windows Event Log" as Marius suggested in that thread

results of "openscad --info" as as follows

C:\Program Files (x86)\OpenSCAD>openscad --info
OpenSCAD Version: 2015.03
System information: Windows 7 (v6.1.0.0) 4 CPUs WOW64 3.80 GB RAM
Compiler, build date: GCC "4.9.2" 32bit, Mar 10 2015
Boost version: 1_57
Eigen version: 3.2.2
CGAL version, kernels: 4.5, Cartesian<Gmpq>, Extended_cartesian<Gmpq>, Epeck
OpenCSG version: OpenCSG 1.3.2
Qt version: 5.4.0
QScintilla version: 2.8.4
MingW build: MingW32
GLib version: 2.42.1
Application Path: C:/Program Files (x86)/OpenSCAD
Documents Path: C:\Users\Leef_me\Documents
Resource Path: C:/Program Files (x86)/OpenSCAD
User Library Path: C:/Users/Leef_me/Documents/OpenSCAD/libraries
User Config Path: C:\Users\Leef_me\AppData\Local/OpenSCAD
Backup Path: C:/Users/Leef_me/Documents/OpenSCAD/backups
OPENSCADPATH: <not set>
OpenSCAD library path:
  C:/Users/Leef_me/Documents/OpenSCAD/libraries
  C:/Program Files (x86)/OpenSCAD\libraries

OPENSCAD_FONT_PATH: <not set>
OpenSCAD font path:


Warning: Cannot create stencil buffer (GL_EXT_packed_depth_stencil not supported
)
GLEW version: 1.11.0
OpenGL Version: 2.1.0 - Build 8.15.10.2025
GL Renderer: Intel(R) Graphics Media Accelerator HD
GL Vendor: Intel
RGBA(8888), depth(24), stencil(0)
GL_ARB_framebuffer_object: no
GL_EXT_framebuffer_object: yes
GL_EXT_packed_depth_stencil: no
GL context creator: WGL
PNG generator: lodepng
OS info: Microsoft(TM) Windows(TM) 6 1 7600 0x24deca0 x86
Machine: 586
OpenGL Program Link OK:
No errors.


Any help would be appreciated.
Thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: gui doesn't work in new version

kintel
Administrator
What specifically do you mean by "does not work" ?
Any errors? does it just quit? does it crash?

For the Event Log, see e.g. http://windows.microsoft.com/en-us/windows/open-event-viewer

Could you try without using an USB-display adapter, to see if that causes the problem?

 -Marius