echoing < and > characters

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

echoing < and > characters

kitwallace
I've only just noticed that

echo("< abc >");
echo("&lt; abc &gt;");

produces different output between versions 2015-03 and 2019-05

in the former the output from both lines is the same, in the later, the
first line is blank - plays havoc with my SVG generation!

bug or feature?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: echoing < and > characters

nophead
Ii is a side effect of changing the log to be scrolling, a new class was used. It now follows normal HTML rules IIRC.

On Tue, 19 Nov 2019 at 12:14, kitwallace <[hidden email]> wrote:
I've only just noticed that

echo("< abc >");
echo("&lt; abc &gt;");

produces different output between versions 2015-03 and 2019-05

in the former the output from both lines is the same, in the later, the
first line is blank - plays havoc with my SVG generation!

bug or feature?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org