compile error

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

compile error

Gordon Wrigley
I'm trying to compile https://github.com/openscad/openscad.git and I'm getting the following error:

qt4 -Isrc -I/usr/X11R6/include -Iobjects -Iobjects -o objects/mainwin.o src/mainwin.cc
src/mainwin.cc: In member function ‘void MainWindow::helpLibrary()’:
src/mainwin.cc:1741:10: error: ‘OPENCSG_VERSION_STRING’ was not declared in this scope
make: *** [objects/mainwin.o] Error 1

any suggestions?
Reply | Threaded
Open this post in threaded view
|

Re: compile error

Gordon Wrigley
Commenting out the relevant bit got it compiling and it seems to work. I noticed a few warnings along the way, I'm not sure if that is expected so I've attached a complete log of the build in case anyone wants to look into it. If you want any other debug info let me know.

How do I run the tests?

Also what tab width is intended with this code? I've noticed a couple of lines indented with >30 tabs.

G

On Tue, Feb 21, 2012 at 7:41 PM, Gordon Wrigley <[hidden email]> wrote:
I'm trying to compile https://github.com/openscad/openscad.git and I'm getting the following error:

qt4 -Isrc -I/usr/X11R6/include -Iobjects -Iobjects -o objects/mainwin.o src/mainwin.cc
src/mainwin.cc: In member function ‘void MainWindow::helpLibrary()’:
src/mainwin.cc:1741:10: error: ‘OPENCSG_VERSION_STRING’ was not declared in this scope
make: *** [objects/mainwin.o] Error 1

any suggestions?

Reply | Threaded
Open this post in threaded view
|

Re: compile error

kintel
Administrator
In reply to this post by Gordon Wrigley
On Feb 21, 2012, at 09:41 AM, Gordon Wrigley wrote:

> qt4 -Isrc -I/usr/X11R6/include -Iobjects -Iobjects -o objects/mainwin.o src/mainwin.cc
> src/mainwin.cc: In member function ‘void MainWindow::helpLibrary()’:
> src/mainwin.cc:1741:10: error: ‘OPENCSG_VERSION_STRING’ was not declared in this scope

You need OpenCSG >= 1.3.2.
You might be lucky and get it working with an older version, but it's strongly recommended to use 1.3.2.

 -Marius


Reply | Threaded
Open this post in threaded view
|

Re: compile error

Gordon Wrigley
Ah, I currently have 1.3.1-4, I looked around for 1.3.2 debs but couldn't find any, do you know of any?

On Tue, Feb 21, 2012 at 8:12 PM, Marius Kintel <[hidden email]> wrote:
On Feb 21, 2012, at 09:41 AM, Gordon Wrigley wrote:

> qt4 -Isrc -I/usr/X11R6/include -Iobjects -Iobjects -o objects/mainwin.o src/mainwin.cc
> src/mainwin.cc: In member function ‘void MainWindow::helpLibrary()’:
> src/mainwin.cc:1741:10: error: ‘OPENCSG_VERSION_STRING’ was not declared in this scope

You need OpenCSG >= 1.3.2.
You might be lucky and get it working with an older version, but it's strongly recommended to use 1.3.2.

 -Marius

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://rocklinux.net/mailman/listinfo/openscad

Reply | Threaded
Open this post in threaded view
|

Re: compile error

kintel
Administrator

On Feb 21, 2012, at 10:15 AM, Gordon Wrigley wrote:

> Ah, I currently have 1.3.1-4, I looked around for 1.3.2 debs but couldn't find any, do you know of any?
>
Chrysn is working on them I think: https://launchpad.net/~chrysn/+archive/openscad

 -Marius


Reply | Threaded
Open this post in threaded view
|

Re: compile error

donbright
In reply to this post by Gordon Wrigley
> How do I run the tests?

cd tests && cmake . && make && ctest

Please see the file doc/testing.txt for more detail. Also the 'build
openscad under linux/unix' page has just been updated in the wikibooks
OpenSCAD Manual with info from testing.txt

-DB

Reply | Threaded
Open this post in threaded view
|

Re: compile error

chrysn
In reply to this post by Gordon Wrigley
On Tue, Feb 21, 2012 at 08:15:52PM +1100, Gordon Wrigley wrote:
> Ah, I currently have 1.3.1-4, I looked around for 1.3.2 debs but couldn't
> find any, do you know of any?

the issue with pre-oneiric is that they ship libglew < 1.5.4, while
opencsg-1.3.2 uses the ARB_occlusion_query2 symbol introduced in 1.5.4.
(what adds to the confusion is that for reasons beyond my grasp, they
went for 1.5.7, later reverted to 1.5.2 without lowering the version
number again just because some window manager stuff (ok, compiz) broke;
they ship something they call 1.5.7.is.1.5.2).

i currently don't have an ubuntu workstation at hand (just my build
server). could you, if you feel confident with manually installing
stuff and know how to get rid of it again, try manually downloading and
installing the following packages:

* http://ubuntu.mirror.cambrium.nl/ubuntu//pool/universe/g/glew/libglew1.6_1.6.0-3_i386.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/libopencsg1_1.3.2-1oneiric2_i386.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/openscad_2011.12-2oneiric1_i386.deb

(or, on 64bit systems)

* http://ubuntu.mirror.cambrium.nl/ubuntu//pool/universe/g/glew/libglew1.6_1.6.0-3_amd64.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/libopencsg1_1.3.2-1oneiric2_amd64.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/openscad_2011.12-2oneiric1_amd64.deb

as natty didn't have a libglew1.6 itself, that shouldn't cause any
conflicts.

please report back whether that works; if so, i'll try to put that into
the ppa as a backport, and the problems with pre-oneiric should be
solved.

regards
chrysn

--
When others do a foolish thing, you should tell them it is a foolish
thing. They can still continue to do it, but at least the truth is where
it needs to be.
  -- Dukhat

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: compile error

Gordon Wrigley
The first two went in fine, then I hit this on the openscad deb:

Dependency is not satisfiable: libboost-program-options1.46.1 (>= 1.46.1-1)

G

On Wed, Feb 22, 2012 at 11:09 PM, chrysn <[hidden email]> wrote:
On Tue, Feb 21, 2012 at 08:15:52PM +1100, Gordon Wrigley wrote:
> Ah, I currently have 1.3.1-4, I looked around for 1.3.2 debs but couldn't
> find any, do you know of any?

the issue with pre-oneiric is that they ship libglew < 1.5.4, while
opencsg-1.3.2 uses the ARB_occlusion_query2 symbol introduced in 1.5.4.
(what adds to the confusion is that for reasons beyond my grasp, they
went for 1.5.7, later reverted to 1.5.2 without lowering the version
number again just because some window manager stuff (ok, compiz) broke;
they ship something they call 1.5.7.is.1.5.2).

i currently don't have an ubuntu workstation at hand (just my build
server). could you, if you feel confident with manually installing
stuff and know how to get rid of it again, try manually downloading and
installing the following packages:

* http://ubuntu.mirror.cambrium.nl/ubuntu//pool/universe/g/glew/libglew1.6_1.6.0-3_i386.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/libopencsg1_1.3.2-1oneiric2_i386.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/openscad_2011.12-2oneiric1_i386.deb

(or, on 64bit systems)

* http://ubuntu.mirror.cambrium.nl/ubuntu//pool/universe/g/glew/libglew1.6_1.6.0-3_amd64.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/libopencsg1_1.3.2-1oneiric2_amd64.deb
* https://launchpad.net/~chrysn/+archive/openscad/+files/openscad_2011.12-2oneiric1_amd64.deb

as natty didn't have a libglew1.6 itself, that shouldn't cause any
conflicts.

please report back whether that works; if so, i'll try to put that into
the ppa as a backport, and the problems with pre-oneiric should be
solved.

regards
chrysn

--
When others do a foolish thing, you should tell them it is a foolish
thing. They can still continue to do it, but at least the truth is where
it needs to be.
 -- Dukhat

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://rocklinux.net/mailman/listinfo/openscad


Reply | Threaded
Open this post in threaded view
|

Re: compile error

chrysn
On Wed, Feb 22, 2012 at 11:17:48PM +1100, Gordon Wrigley wrote:
> The first two went in fine, then I hit this on the openscad deb:
>
> Dependency is not satisfiable: libboost-program-options1.46.1 (>= 1.46.1-1)

you can satisfy that for 64bit from

http://ubuntu.mirror.cambrium.nl/ubuntu//pool/main/b/boost1.46/libboost-program-options1.46.1_1.46.1-5ubuntu2_amd64.deb

or for 32bit from

http://ubuntu.mirror.cambrium.nl/ubuntu//pool/main/b/boost1.46/libboost-program-options1.46.1_1.46.1-5ubuntu2_i386.deb

-- please let me know if that makes everything work; but the critical
stuff is afaict over, so i'll try to provide lucid/natty/maverick
packages for everything again using a backported glew too.

thank
chrysn

--
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: compile error

Gordon Wrigley
I gave this another go, after libboost-program-options it wanted libboost-thread and that in turn wanted:

Dependency is not satisfiable: libstdc++6 (>= 4.6)

Which I'm reluctant to mess with.

G

On Thu, Feb 23, 2012 at 1:33 AM, chrysn <[hidden email]> wrote:
On Wed, Feb 22, 2012 at 11:17:48PM +1100, Gordon Wrigley wrote:
> The first two went in fine, then I hit this on the openscad deb:
>
> Dependency is not satisfiable: libboost-program-options1.46.1 (>= 1.46.1-1)

you can satisfy that for 64bit from

http://ubuntu.mirror.cambrium.nl/ubuntu//pool/main/b/boost1.46/libboost-program-options1.46.1_1.46.1-5ubuntu2_amd64.deb

or for 32bit from

http://ubuntu.mirror.cambrium.nl/ubuntu//pool/main/b/boost1.46/libboost-program-options1.46.1_1.46.1-5ubuntu2_i386.deb

-- please let me know if that makes everything work; but the critical
stuff is afaict over, so i'll try to provide lucid/natty/maverick
packages for everything again using a backported glew too.

thank
chrysn

--
To use raw power is to make yourself infinitely vulnerable to greater powers.
 -- Bene Gesserit axiom

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://rocklinux.net/mailman/listinfo/openscad


Reply | Threaded
Open this post in threaded view
|

Re: compile error

chrysn
On Thu, Feb 23, 2012 at 07:17:23AM +1100, Gordon Wrigley wrote:
> Dependency is not satisfiable: libstdc++6 (>= 4.6)
>
> Which I'm reluctant to mess with.

which is totally understandable. i'm in the progress of backporting
everything needed, but everything takes some time to build.

thanks for your help, i'll let the list know when there is progress.

regards
chrysn

--
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

signature.asc (836 bytes) Download Attachment