boost 1.48

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

boost 1.48

David Goodenough
I notice that debian sid has moved from libboost 1.46 to 1.48, and
all the 1.46 stuff has now been replaced.  When I compile openscad
I get a message at the end of the make which said:-

/usr/bin/ld: warning: libboost_thread.so.1.46.1, needed by
/usr/lib/libCGAL.so, may conflict with libboost_thread.so.1.48.0

Is there a version of libCGAL.so which uses 1.48?

David

Reply | Threaded
Open this post in threaded view
|

Re: boost 1.48

Alan Cox
On Fri, 10 Feb 2012 12:04:22 +0000
David Goodenough <[hidden email]> wrote:

> I notice that debian sid has moved from libboost 1.46 to 1.48, and
> all the 1.46 stuff has now been replaced.  When I compile openscad
> I get a message at the end of the make which said:-
>
> /usr/bin/ld: warning: libboost_thread.so.1.46.1, needed by
> /usr/lib/libCGAL.so, may conflict with libboost_thread.so.1.48.0
>
> Is there a version of libCGAL.so which uses 1.48?

You should just be able to rebuild libCGAL as well.

Reply | Threaded
Open this post in threaded view
|

Re: boost 1.48

David Goodenough
On Friday 10 Feb 2012, Alan Cox wrote:

> On Fri, 10 Feb 2012 12:04:22 +0000
>
> David Goodenough <[hidden email]> wrote:
> > I notice that debian sid has moved from libboost 1.46 to 1.48, and
> > all the 1.46 stuff has now been replaced.  When I compile openscad
> > I get a message at the end of the make which said:-
> >
> > /usr/bin/ld: warning: libboost_thread.so.1.46.1, needed by
> > /usr/lib/libCGAL.so, may conflict with libboost_thread.so.1.48.0
> >
> > Is there a version of libCGAL.so which uses 1.48?
>
> You should just be able to rebuild libCGAL as well.
> _______________________________________________
> OpenSCAD mailing list
> [hidden email]
> http://rocklinux.net/mailman/listinfo/openscad
I got it from Debian, so I will have to ask them to rebuild - the
dependency looks to be wrong.

David