Severe lag when rotating model in viewing area

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Severe lag when rotating model in viewing area

leebc
This post has NOT been accepted by the mailing list yet.
I've been running the older version of OpenSCAD that came with Ubunti 14.04 on an OLDER (10 years old) laptop, and have just switched to Ubuntu 16.04 on a "newer" laptop.  I was not experiencing this problem before.

When I try to drag and rotate an object, there is severe lag in the graphical redraw.  On the magnitude of taking 5 seconds to rotate 5 degrees. and precessing from there, refreshing a new rotation every few seconds until it finally catches up with me 30+ seconds later.
My current setup is:
     Ubuntu (Lubuntu) 16.04
     OpenSCAD 2015.03-1 (the Ubuntu package
     Sony Vaio laptop with
          Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)

I have looked into the video card, and from what I've found, this should use the i915 driver.  Intel releases drivers for this card, and the latest version (from this spring) is listed on Intel's site as included in Ubuntu 16.04.

Can someone point me in a direction I can go to  try to resolve this issue?
I really don't think I should be having a worse experience on new system with a faster processor, more RAM and a never version of openscad.

Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

MichaelAtOz
Administrator
Hi, welcome to the forum. Your post is still flagged as "This post has NOT been accepted by the mailing list yet", so nobody gets it unless they look.
You need to subscribe to the mailing list, and respond to the registration email.

I have quoted it below for others to see.

Intel video has been problematic.

Until someone with more direct Intel based experience replies, try setting the
Edit/Preferences/Advanced-tab/Force-goldfeather option.
Tho I think that has more an effect on the graphics looking wrong, but you never know.

Oh, and posting the content of Help/Library-info will probably help.

leebc wrote
I've been running the older version of OpenSCAD that came with Ubunti 14.04 on an OLDER (10 years old) laptop, and have just switched to Ubuntu 16.04 on a "newer" laptop.  I was not experiencing this problem before.

When I try to drag and rotate an object, there is severe lag in the graphical redraw.  On the magnitude of taking 5 seconds to rotate 5 degrees. and precessing from there, refreshing a new rotation every few seconds until it finally catches up with me 30+ seconds later.
My current setup is:
     Ubuntu (Lubuntu) 16.04
     OpenSCAD 2015.03-1 (the Ubuntu package
     Sony Vaio laptop with
          Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)

I have looked into the video card, and from what I've found, this should use the i915 driver.  Intel releases drivers for this card, and the latest version (from this spring) is listed on Intel's site as included in Ubuntu 16.04.

Can someone point me in a direction I can go to  try to resolve this issue?
I really don't think I should be having a worse experience on new system with a faster processor, more RAM and a never version of openscad.
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

leebc
Thanks MichaelAtOz.  I'm subscribing to the mailing list now.

I have heard people complaining about  Intel graphics in the past, but I was hoping that Intel providing drivers would help in this case.  The laptop was free, so I can only complain a little.


I did try changing the Force Goldfeather and Enable for OpenGL 1.x options a few  days ago, but it didn't seem to help.  I'll try it again.

Here's my Help/Library-info

OpenSCAD Version: 2015.03-1
System information: Linux 4.4.0-42-generic #62-Ubuntu SMP Fri Oct 7 23:10:22 UTC 2016 i686 Ubuntu 16.04.1 LTS 2 CPUs 16777216.00 TB RAM
Compiler: GCC "5.2.1 20151028" 32bit
Boost version: 1_58
Eigen version: 3.2.5
CGAL version, kernels: 4.7, Cartesian, Extended_cartesian, Epeck
OpenCSG version: OpenCSG 1.4.0
Qt version: 5.5.1
QScintilla version: 2.9.1
MingW build: No
GLib version: 2.47.1
Application Path: /usr/bin
Documents Path: /home/leebc/.local/share
Resource Path: /usr/share/openscad
User Library Path: /home/leebc/.local/share/OpenSCAD/libraries
User Config Path: /home/leebc/.config/OpenSCAD
Backup Path: /home/leebc/.local/share/OpenSCAD/backups
OPENSCADPATH:
OpenSCAD library path:
/home/leebc/.local/share/OpenSCAD/libraries
/usr/share/openscad/libraries

OPENSCAD_FONT_PATH:
OpenSCAD font path:
GLEW version: 1.13.0
OpenGL Version: 2.1 Mesa 11.2.0
GL Renderer: Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
GL Vendor: Intel Open Source Technology Center
RGBA(8880), depth(24), stencil(8)
GL_ARB_framebuffer_object: yes
GL_EXT_framebuffer_object: yes
GL_EXT_packed_depth_stencil: yes

Using QGLWidget

GL Extensions:
GL_3DFX_texture_compression_FXT1
GL_AMD_seamless_cubemap_per_texture
GL_AMD_shader_trinary_minmax
GL_ANGLE_texture_compression_dxt3
GL_ANGLE_texture_compression_dxt5
GL_APPLE_object_purgeable
GL_APPLE_packed_pixels
GL_APPLE_vertex_array_object
GL_ARB_ES2_compatibility
GL_ARB_arrays_of_arrays
GL_ARB_buffer_storage
GL_ARB_clear_buffer_object
GL_ARB_clear_texture
GL_ARB_clip_control
GL_ARB_color_buffer_float
GL_ARB_compressed_texture_pixel_storage
GL_ARB_copy_buffer
GL_ARB_copy_image
GL_ARB_debug_output
GL_ARB_depth_buffer_float
GL_ARB_depth_clamp
GL_ARB_depth_texture
GL_ARB_draw_buffers
GL_ARB_draw_elements_base_vertex
GL_ARB_draw_instanced
GL_ARB_explicit_attrib_location
GL_ARB_explicit_uniform_location
GL_ARB_fragment_coord_conventions
GL_ARB_fragment_program
GL_ARB_fragment_program_shadow
GL_ARB_fragment_shader
GL_ARB_framebuffer_object
GL_ARB_framebuffer_sRGB
GL_ARB_get_program_binary
GL_ARB_get_texture_sub_image
GL_ARB_half_float_pixel
GL_ARB_half_float_vertex
GL_ARB_instanced_arrays
GL_ARB_internalformat_query
GL_ARB_invalidate_subdata
GL_ARB_map_buffer_alignment
GL_ARB_map_buffer_range
GL_ARB_multi_bind
GL_ARB_multisample
GL_ARB_multitexture
GL_ARB_occlusion_query
GL_ARB_occlusion_query2
GL_ARB_pipeline_statistics_query
GL_ARB_pixel_buffer_object
GL_ARB_point_parameters
GL_ARB_point_sprite
GL_ARB_program_interface_query
GL_ARB_provoking_vertex
GL_ARB_robustness
GL_ARB_sampler_objects
GL_ARB_seamless_cube_map
GL_ARB_seamless_cubemap_per_texture
GL_ARB_separate_shader_objects
GL_ARB_shader_bit_encoding
GL_ARB_shader_draw_parameters
GL_ARB_shader_objects
GL_ARB_shader_texture_lod
GL_ARB_shading_language_100
GL_ARB_shadow
GL_ARB_sync
GL_ARB_texture_barrier
GL_ARB_texture_border_clamp
GL_ARB_texture_compression
GL_ARB_texture_compression_rgtc
GL_ARB_texture_cube_map
GL_ARB_texture_env_add
GL_ARB_texture_env_combine
GL_ARB_texture_env_crossbar
GL_ARB_texture_env_dot3
GL_ARB_texture_float
GL_ARB_texture_mirror_clamp_to_edge
GL_ARB_texture_mirrored_repeat
GL_ARB_texture_non_power_of_two
GL_ARB_texture_rectangle
GL_ARB_texture_rg
GL_ARB_texture_rgb10_a2ui
GL_ARB_texture_storage
GL_ARB_texture_swizzle
GL_ARB_transpose_matrix
GL_ARB_vertex_array_bgra
GL_ARB_vertex_array_object
GL_ARB_vertex_attrib_binding
GL_ARB_vertex_buffer_object
GL_ARB_vertex_program
GL_ARB_vertex_shader
GL_ARB_vertex_type_10f_11f_11f_rev
GL_ARB_vertex_type_2_10_10_10_rev
GL_ARB_window_pos
GL_ATI_blend_equation_separate
GL_ATI_draw_buffers
GL_ATI_separate_stencil
GL_ATI_texture_env_combine3
GL_ATI_texture_float
GL_EXT_abgr
GL_EXT_bgra
GL_EXT_blend_color
GL_EXT_blend_equation_separate
GL_EXT_blend_func_separate
GL_EXT_blend_minmax
GL_EXT_blend_subtract
GL_EXT_compiled_vertex_array
GL_EXT_copy_texture
GL_EXT_draw_buffers2
GL_EXT_draw_instanced
GL_EXT_draw_range_elements
GL_EXT_fog_coord
GL_EXT_framebuffer_blit
GL_EXT_framebuffer_object
GL_EXT_framebuffer_sRGB
GL_EXT_gpu_program_parameters
GL_EXT_multi_draw_arrays
GL_EXT_packed_depth_stencil
GL_EXT_packed_float
GL_EXT_packed_pixels
GL_EXT_pixel_buffer_object
GL_EXT_point_parameters
GL_EXT_polygon_offset
GL_EXT_polygon_offset_clamp
GL_EXT_provoking_vertex
GL_EXT_rescale_normal
GL_EXT_secondary_color
GL_EXT_separate_specular_color
GL_EXT_shadow_funcs
GL_EXT_stencil_two_side
GL_EXT_stencil_wrap
GL_EXT_subtexture
GL_EXT_texture
GL_EXT_texture3D
GL_EXT_texture_array
GL_EXT_texture_compression_dxt1
GL_EXT_texture_compression_rgtc
GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp
GL_EXT_texture_env_add
GL_EXT_texture_env_combine
GL_EXT_texture_env_dot3
GL_EXT_texture_filter_anisotropic
GL_EXT_texture_integer
GL_EXT_texture_lod_bias
GL_EXT_texture_object
GL_EXT_texture_rectangle
GL_EXT_texture_sRGB
GL_EXT_texture_sRGB_decode
GL_EXT_texture_shared_exponent
GL_EXT_texture_snorm
GL_EXT_texture_swizzle
GL_EXT_vertex_array
GL_EXT_vertex_array_bgra
GL_IBM_multimode_draw_arrays
GL_IBM_rasterpos_clip
GL_IBM_texture_mirrored_repeat
GL_INGR_blend_func_separate
GL_KHR_context_flush_control
GL_KHR_debug
GL_MESA_pack_invert
GL_MESA_texture_signed_rgba
GL_MESA_window_pos
GL_NV_blend_square
GL_NV_conditional_render
GL_NV_depth_clamp
GL_NV_light_max_exponent
GL_NV_packed_depth_stencil
GL_NV_primitive_restart
GL_NV_texgen_reflection
GL_NV_texture_barrier
GL_NV_texture_env_combine4
GL_NV_texture_rectangle
GL_OES_EGL_image
GL_OES_read_format
GL_S3_s3tc
GL_SGIS_generate_mipmap
GL_SGIS_texture_border_clamp
GL_SGIS_texture_edge_clamp
GL_SGIS_texture_lod
GL_SUN_multi_draw_arrays
tp3
Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

tp3
leebc wrote
> I did try changing the Force Goldfeather and Enable
> for OpenGL 1.x options a few days ago, but it didn't
> seem to help. I'll try it again.
>
From what I've read, the Goldfeather algorithm tends to
be a bit slower than the default SCS algorithm, but helps
in some cases of driver issues. This does not seem to
be relevant in this specific case though.

> Can someone point me in a direction I can go to try to
> resolve this issue?
>
There are two issues related to display performance. One
is caused by changes in the GUI library. This at least
happens for you as the library info shows:

  Qt version: 5.5.1
  Using QGLWidget

You could try with the nightly builds that still use
Qt4 where that specific issue is not there.

The Debian repository has a version 2015.03-2+dfsg-1
which includes the update for the new Display Widget,
(which would show up as "Using QOpenGLWidget") but is
stuck in the experimental repo for some reason.

The other issue is that the whole display code would
need some improvements to make use of the graphics card
feature available nowdays. I'm not aware someone is
working on that. So if the reason for the slow display
is "simply" a huge amount of vertices, there's no fix
at this time.

ciao,
  Torsten.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

leebc
-- Update --

Thank you, Torsten.

I've since upgraded to "newer" hardware (circa 2011) with an AMD Mobility
Radeon HD 5430/5450/5470,  but since I'm running the exact same OS and
packages, I had the same problem.

Per your suggestion, what I've done this morning is configure the PPA
and installed OpenSCAD 2015.03-2+dfsg-1~xenial as described here:
        https://launchpad.net/~openscad/+archive/ubuntu/releases

I now have:
        OpenSCAD Version: 2015.03-2
        Qt version: 5.5.1
        Using QOpenGLWidget

It's DEFINATELY rendering and rotating much better than before.
I've tested 3 SCAD files with good results:
        A model with many unions, differences and intersections
        An animation with a couple differences
and surface() PNG model.

All work great (though the surface() is slow from a stupidly high number of
polygons).

Thank you very much for your help.



I just realized that in my original "Lib & Build info" it incorrectly
shows that I had "16777216.00 TB RAM".  My updated version correctly shows
1.89 GB RAM.
Should I file a bug on this?

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
tp3
Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

tp3
On 10/30/2016 05:49 PM, Bryan Lee wrote:
> It's DEFINATELY rendering and rotating much better than
> before.
>
Great.

> All work great (though the surface() is slow from a
> stupidly high number of polygons).
>
Yep, that's the other issue I mentioned. This needs
quite some work, but that will happen eventually.

> I just realized that in my original "Lib & Build info" it
> incorrectly shows that I had "16777216.00 TB RAM".  My
> updated version correctly shows 1.89 GB RAM.
> Should I file a bug on this?
>
If it shows up fine in the latest version, there's no
need for a bug report anymore.

ciao,
  Torsten.




_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

mmccool
In reply to this post by leebc
I don't think this is an Intel graphics issue; it is just worse under lower performing graphics cards (eg in laptops, or systems with only processor graphics).   I have an NVIDIA GPU in my laptop and see the same problem (although I have a fairly high-end laptop).  If you test with a fast desktop GPU or a simple model it may not show up.   The model I am using also has a lot of CSG operations (which in preview mode involve multiple passes to render...).

I think what is happening is that the queue of commands to change the view generated when dragging the mouse is growing faster than the graphics system can render.   Then even after the mouse is released, the queue drains only as fast as the system can render.   Note the problem also occurs with panning, not just rotation (and panning is even more annoying as the model drifts out of view and you have to hunt around, carefully because of the lag, to bring it back).

With this issue the system is only barely usable as you have to reposition the model with very short "bursts".   Also, this is not a pure performance issue: I have used exactly the same model and the same GPU to work with models under OpenSCAD in the past with no problem.

This is, simply put, a recently introduced user interface bug.  What the system should do is "jump" to the last movement command given in the queue each time it does a render, flushing the event/command queue of any pending requests, to keep it from growing uncontrollably.
Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

mmccool
I should mention I'm using version 2015.03-1.   I'll try upgrading to a more recent development version to see if the issue has been resolved.
Reply | Threaded
Open this post in threaded view
|

Re: Severe lag when rotating model in viewing area

mmccool
I upgraded to 2015.03-2 (from the ppa) and the problem is gone.   Unfortunately this version also fails to work with Intel graphics (which I also have on my Skylake laptop) under Ubuntu 16.04.   I tried openscad-nightly as well.   The problem is (still) fixed there, but that version also does not load properly with Intel graphics (it gets farther along, but fails to find certain OpenGL extensions).