Round shapes created in openscad are not smooth but hexigonal

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Round shapes created in openscad are not smooth but hexigonal

FourthDr
This post was updated on .
I was trying to make a coin for a friend to 3D print with a bossing on top. I
noticed that the coin or solid cylinder has a rough hexagonal shape to it.
How do I get a smooth round texture instead of the hex looking couture? I
also notice that round 3D models I modify in tinkercad then export to STL
also have a hexagonal surface after being exported, when they where
originally round without any noticeable hexigonalness. What's going on here?
How do I fix this problem? Could someone maybe provide some simple example
code?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
Discuss@lists.openscad.org
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

nophead
STL files only contain triangular facets so you can't have a true arc, only a faceted approximation.

Similarly OpenSCAD represents all shapes with a boundary mesh made of polygonal facets.

You can have as many facets as you want by setting $fn, you are not limited to octogons. Higher values of $fn will slow down OpenSCAD.

You can also specify the minimum angle $fa and the minimum edge length with $fs. This allows the number of edges to be set adaptively according to how big the circle is.

For 3D printing I set $fa to 6 and $fa to half the extrusion width. That gives 60 sides for large circles (best to make it a multiple of four). Smaller circles hit the $fa limit and have less sides.

On 31 August 2018 at 05:49, FourthDr <[hidden email]> wrote:
I was trying to make a coin for a friend to 3D print with a bossing on top. I
noticed that the coin or solid cylinder has a rough hexagonal shape to it.
How do I get a smooth round texture instead of the hex looking couture? I
also notice that round 3D models I modify in tinkercad then export to STL
also have a hexagonal surface after being exported, when they there
originally round without any noticeable hexigonalness. What's going on here?
How do I fix this problem? Could someone maybe provide some simple example
code?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

peetersm
nop head did you mean? " For 3D printing I set $fa to 6 and $fs to half the extrusion width. That gives 60 sides for large circles (best to make it a multiple of four). Smaller circles hit the $fs limit and have less sides"

On Fri, Aug 31, 2018 at 3:44 AM nop head <[hidden email]> wrote:
STL files only contain triangular facets so you can't have a true arc, only a faceted approximation.

Similarly OpenSCAD represents all shapes with a boundary mesh made of polygonal facets.

You can have as many facets as you want by setting $fn, you are not limited to octogons. Higher values of $fn will slow down OpenSCAD.

You can also specify the minimum angle $fa and the minimum edge length with $fs. This allows the number of edges to be set adaptively according to how big the circle is.

For 3D printing I set $fa to 6 and $fa to half the extrusion width. That gives 60 sides for large circles (best to make it a multiple of four). Smaller circles hit the $fa limit and have less sides.

On 31 August 2018 at 05:49, FourthDr <[hidden email]> wrote:
I was trying to make a coin for a friend to 3D print with a bossing on top. I
noticed that the coin or solid cylinder has a rough hexagonal shape to it.
How do I get a smooth round texture instead of the hex looking couture? I
also notice that round 3D models I modify in tinkercad then export to STL
also have a hexagonal surface after being exported, when they there
originally round without any noticeable hexigonalness. What's going on here?
How do I fix this problem? Could someone maybe provide some simple example
code?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

nophead
Yes, sorry, typos that I thought I had already corrected before pressing send.

On 31 August 2018 at 09:03, Mark Peeters <[hidden email]> wrote:
nop head did you mean? " For 3D printing I set $fa to 6 and $fs to half the extrusion width. That gives 60 sides for large circles (best to make it a multiple of four). Smaller circles hit the $fs limit and have less sides"

On Fri, Aug 31, 2018 at 3:44 AM nop head <[hidden email]> wrote:
STL files only contain triangular facets so you can't have a true arc, only a faceted approximation.

Similarly OpenSCAD represents all shapes with a boundary mesh made of polygonal facets.

You can have as many facets as you want by setting $fn, you are not limited to octogons. Higher values of $fn will slow down OpenSCAD.

You can also specify the minimum angle $fa and the minimum edge length with $fs. This allows the number of edges to be set adaptively according to how big the circle is.

For 3D printing I set $fa to 6 and $fa to half the extrusion width. That gives 60 sides for large circles (best to make it a multiple of four). Smaller circles hit the $fa limit and have less sides.

On 31 August 2018 at 05:49, FourthDr <[hidden email]> wrote:
I was trying to make a coin for a friend to 3D print with a bossing on top. I
noticed that the coin or solid cylinder has a rough hexagonal shape to it.
How do I get a smooth round texture instead of the hex looking couture? I
also notice that round 3D models I modify in tinkercad then export to STL
also have a hexagonal surface after being exported, when they there
originally round without any noticeable hexigonalness. What's going on here?
How do I fix this problem? Could someone maybe provide some simple example
code?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

FourthDr
This post was updated on .
In reply to this post by nophead
Thanks Nophead for the reply. In a related question, since I am making a
model from scratch I need to know what units of measure are being used. I
see a scale in increments of 10. But is that inches or mm? Or something
else? I need to know how big the object is going to be and that it is the
correct size.

Updated: Right after I posted this I see it is mm. Is there a way to change to other units?

Also, why use $fa $fs as apposed to $fn?

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
Discuss@lists.openscad.org
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

cacb
On 2018-09-01 10:04, FourthDr wrote:
> Thanks Nophead for the reply. In a related question, since I am making
> a
> model from scratch I need to know what units of measure are being used.
> I
> see a scale in increments of 10. But is that inches or mm? Or something
> else? I need to know how big the object is going to be and that it is
> the
> correct size.

The models are unit-less. However, in 3d printing a common convention is
to use mm. If you prefer to work in other units, you can scale the final
result to mm easily.

Carsten Arnholm

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

FourthDr
Export to STL seems to be in mm. But I didn't set any units.



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

nophead
STL is unit-less also. It is the slicer in a 3D printing chain that decides 1 unit is 1mm.

On 1 September 2018 at 09:30, FourthDr <[hidden email]> wrote:
Export to STL seems to be in mm. But I didn't set any units.



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Round shapes created in openscad are not smooth but hexigonal

RobWLakes
.STL in mm is just a very happy coincidence, or someone's very good anticipation for an important technology. Thanks folks!!
Cheers, RobW

On 1 September 2018 7:00:33 pm AEST, nop head <[hidden email]> wrote:
STL is unit-less also. It is the slicer in a 3D printing chain that decides 1 unit is 1mm.

On 1 September 2018 at 09:30, FourthDr <[hidden email]> wrote:
Export to STL seems to be in mm. But I didn't set any units.



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Rob W
Lake Tyers Beach,
Victoria, Australia