Problem using OpenSCAD on Windows 10

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem using OpenSCAD on Windows 10

RocketMan1961
I just installed the latest version of OpenSCAD on my Windows 10 laptop (64 bit). When I try to run it, it opens but I can't open any SCAD files. I get an error that says Error LoadLibrary failed with error 1114: A dynamic link library (DLL) initialization routine failed. Any thoughts? Thank you. Tim

Sent from the OpenSCAD mailing list archive at Nabble.com.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
tp3
Reply | Threaded
Open this post in threaded view
|

Re: Problem using OpenSCAD on Windows 10

tp3
On 14.08.19 01:41, RocketMan1961 wrote:
> I just installed the latest version of OpenSCAD on my Windows
> 10 laptop (64 bit). When I try to run it, it opens but I can't
> open any SCAD files. I get an error that says Error LoadLibrary
> failed with error 1114: A dynamic link library (DLL)
> initialization routine failed. Any thoughts?

Is that maybe a Windows N version without media player?

https://en.wikibooks.org/wiki/OpenSCAD_User_Manual/FAQ#OpenSCAD_fails_to_run_refering_to_EVR.dll,_MF.dll_or_MFPlat.dll_on_Windows

ciao,
  Torsten.


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: Problem using OpenSCAD on Windows 10

RocketMan1961
tp3 wrote

> On 14.08.19 01:41, RocketMan1961 wrote:
>> I just installed the latest version of OpenSCAD on my Windows
>> 10 laptop (64 bit). When I try to run it, it opens but I can't
>> open any SCAD files. I get an error that says Error LoadLibrary
>> failed with error 1114: A dynamic link library (DLL)
>> initialization routine failed. Any thoughts?
>
> Is that maybe a Windows N version without media player?
>
> https://en.wikibooks.org/wiki/OpenSCAD_User_Manual/FAQ#OpenSCAD_fails_to_run_refering_to_EVR.dll,_MF.dll_or_MFPlat.dll_on_Windows
>
> ciao,
>   Torsten.
>
>
> _______________________________________________
> OpenSCAD mailing list

> Discuss@.openscad

> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

Torsten,

No, it's Windows 10 Home, update 1903.
<http://forum.openscad.org/file/t2621/winver.jpg>

Thanks,
Tim



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
tp3
Reply | Threaded
Open this post in threaded view
|

Re: Problem using OpenSCAD on Windows 10

tp3
On 14.08.19 11:08, RocketMan1961 wrote:
> No, it's Windows 10 Home, update 1903.
> <http://forum.openscad.org/file/t2621/winver.jpg>

I don't know if the N variant is shown there. I guess the
question would be: "Do you have the Windows Media Player"
installed?

Maybe someone actually running that N variant could help
finding a place where it's possible to distinguish this
from the "normal" version.

ciao,
  Torsten.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: Problem using OpenSCAD on Windows 10

bradipao
In reply to this post by RocketMan1961
From a quick search on google, it seems this error is in general triggered on
a laptop/notebook with a "low power graphic setting" active. So they
recommend to update graphic drivers and try to set an "high performance"
graphic profile.



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Problem using OpenSCAD on Windows 10

RocketMan1961
Bingo! That was it. I have switchable graphics on this laptop (Intel for low
power and AMD for high power). I selected to use the AMD video for OpenSCAD
and it works!

Thank you everyone for all of your suggestions!

Tim David



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org