Preview Ruined by Difference Including STL

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Preview Ruined by Difference Including STL

JohnB
I'm using OpenSCAD to mess up other people's STLs! It works very well until I
want to cut part of it away using difference(), but then large parts of the
uncut areas disappear in Preview. They're fine when rendered. I've had this
problem since I've been using OpenSCAD on every version I've tried,
including 2019.05. Is this a bug, a know weakness in the software, or a
problem with my computer?

This is my latest bit of vandalism, where I've scaled down and assembled
various STLs from a model from Thingiverse. I want to cut it in half and
mirror it, to make both ends identical. But before I do that I need to cut
out some of the inside. The last time I did this, I was able to cut the
model up into pieces, save each part as an STL, import it, make the join,
and repeat the process, but this time it's not so easy to do that.

This is what I'm talking about. This is the model with the cube I want to
cut away highlighted:
<http://forum.openscad.org/file/t2424/Tram_engine_uncut.png>

This is when it's cut:
<http://forum.openscad.org/file/t2424/Tram_engine_cut.png>

Is there any way to get round this?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Preview Ruined by Difference Including STL

nophead
Does it show correctly with F6? For a correct preview you need to set convexity in the import statement.

On Wed, 12 Jun 2019 at 23:53, JohnB <[hidden email]> wrote:
I'm using OpenSCAD to mess up other people's STLs! It works very well until I
want to cut part of it away using difference(), but then large parts of the
uncut areas disappear in Preview. They're fine when rendered. I've had this
problem since I've been using OpenSCAD on every version I've tried,
including 2019.05. Is this a bug, a know weakness in the software, or a
problem with my computer?

This is my latest bit of vandalism, where I've scaled down and assembled
various STLs from a model from Thingiverse. I want to cut it in half and
mirror it, to make both ends identical. But before I do that I need to cut
out some of the inside. The last time I did this, I was able to cut the
model up into pieces, save each part as an STL, import it, make the join,
and repeat the process, but this time it's not so easy to do that.

This is what I'm talking about. This is the model with the cube I want to
cut away highlighted:
<http://forum.openscad.org/file/t2424/Tram_engine_uncut.png>

This is when it's cut:
<http://forum.openscad.org/file/t2424/Tram_engine_cut.png>

Is there any way to get round this?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Preview Ruined by Difference Including STL

JohnB
That makes a huge difference. It's not perfect, but I can work with it. I've
set it to 5 here, but increasing it doesn't make any useful difference. F6
is fine, but far too slow to be useful until I need it.

Thanks.

<http://forum.openscad.org/file/t2424/With_convexity.png>



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org