OpenSCAD crashes on Render

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSCAD crashes on Render

Oakapple
On F5 (Preview) the model appears with the information below.

Compiling design (CSG Tree generation)...
Compiling design (CSG Products generation)...
Geometries in cache: 12
Geometry cache size in bytes: 8256
CGAL Polyhedrons in cache: 0
CGAL cache size in bytes: 0
Compiling design (CSG Products normalization)...
Normalized CSG tree has 5358 elements
Compile and preview finished.
Total rendering time: 0 hours, 0 minutes, 0 seconds

When using F6 (Render) I get the following error and the application closes.



I'm using OpenSCAD version 2015.03-1 on Windows 7 32-bit Intel i5 2.4gGHz and 3Gb RAM.

Am I just exceeding what the PC is capable of, have I generated an inefficient model, or is something wrong?

Thanks

Colin
Reply | Threaded
Open this post in threaded view
|

Re: OpenSCAD crashes on Render

sgraves
I have had occasions where F5 works but F6 doesn't. I most cases wireframe view (F11) fixes it.  Don't try to drop out of wireframe because then it will crash.  This will allow you to create an STL, if that is your goal.

Steve

Oakapple wrote
On F5 (Preview) the model appears with the information below.

Compiling design (CSG Tree generation)...
Compiling design (CSG Products generation)...
Geometries in cache: 12
Geometry cache size in bytes: 8256
CGAL Polyhedrons in cache: 0
CGAL cache size in bytes: 0
Compiling design (CSG Products normalization)...
Normalized CSG tree has 5358 elements
Compile and preview finished.
Total rendering time: 0 hours, 0 minutes, 0 seconds

When using F6 (Render) I get the following error and the application closes.



I'm using OpenSCAD version 2015.03-1 on Windows 7 32-bit Intel i5 2.4gGHz and 3Gb RAM.

Am I just exceeding what the PC is capable of, have I generated an inefficient model, or is something wrong?

Thanks

Colin