Odd behaviour in preview ...

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

Odd behaviour in preview ...

softfoot
I just noticed this with the latest RC.

If I create a script and "preview" it then it displays as expected but
if I then double click the preview image often the image disappears!!

I have not been able to find a way to restore the preview image, F5
reports no errors but nothing is displayed.

Render works OK.

Am I being silly ? ;-) or is this expected behaviour ?

Dave



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

MichaelAtOz
Administrator
softfoot wrote
> if I then double click the preview image often the image disappears!!
>
> Am I being silly ? ;-) or is this expected behaviour ?

No not expected.
It works for me with 2020.12.RC2.

I presume it does not happen with 2019.05?

It could be a graphics driver issue.
Could you copy Help/Library-info, paste into a file (.txt) & attach.



-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
OpenSCAD Admin - email* me if you need anything, or if I've done something stupid...
* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain;
to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

softfoot
This also happens when I click the previewed object and select one of the menu items, then on the next click the object becomes invisible.

I have discovered that hiding the preview toolbar and re-enabling restores the image !!

This happens in version 2020.12-RC2

Requested info attached.

Regards,
Dave

On 16/12/2020 03:36, MichaelAtOz wrote:
softfoot wrote
if I then double click the preview image often the image disappears!!

Am I being silly ? ;-) or is this expected behaviour ?
No not expected.
It works for me with 2020.12.RC2.

I presume it does not happen with 2019.05?

It could be a graphics driver issue.
Could you copy Help/Library-info, paste into a file (.txt) & attach.



-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
.



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

Dump.txt (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

MichaelAtOz
Administrator
> GL Renderer: Intel(R) HD Graphics

Sometimes Intel Graphics is a problem.
Often enabling Edit/preferences/advanced/force-goldfeather fixes it.

Worth a try first.



-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
OpenSCAD Admin - email* me if you need anything, or if I've done something stupid...
* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain;
to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

nophead
It is the new mouse click to show the code that created the object that is the problem. It drives me crazy. To get your preview back open the editor and close the tab that the mouse click opened and do F5 again.

On Wed, 16 Dec 2020 at 04:18, MichaelAtOz <[hidden email]> wrote:
> GL Renderer: Intel(R) HD Graphics

Sometimes Intel Graphics is a problem.
Often enabling Edit/preferences/advanced/force-goldfeather fixes it.

Worth a try first.



-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

jotweh
It is fixed by now, but the RC has not been uptated yet.

Clicking will not focus your editor anymore, if the editor is hidden.
The root of the problem is (was) that clicking on a list item will focus
your editor to the line, that defined this geometry, even if it is in
another file.


On 16/12/2020 10.20, nop head wrote:
> It is the new mouse click to show the code that created the object
> that is the problem. It drives me crazy. To get your preview back open
> the editor and close the tab that the mouse click opened and do F5 again.
>


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

MichaelAtOz
Administrator
In reply to this post by MichaelAtOz
Note the particular issue was fixed by goldfeather.

> -----Original Message-----
> From: David Slipper [mailto:]
> Sent: Wed, 16 Dec 2020 18:47
> To: MichaelAtOz
> Subject: Re: [OpenSCAD] Odd behaviour in preview ...
>
> Yes, that fixed it !!
>
> Out of curiosity what is "Goldfeather" ???
>
> Many thanks for the prompt action!
> Dave
>
> On 16/12/2020 04:18, MichaelAtOz wrote:
> >> GL Renderer: Intel(R) HD Graphics
> > Sometimes Intel Graphics is a problem.
> > Often enabling Edit/preferences/advanced/force-goldfeather fixes it.
> >
> > Worth a try first.
> >
> >
> >
> > -----
> > OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...
> >
> > * on the Forum, click on my MichaelAtOz label, there is a link to email me.
> >
> > Unless specifically shown otherwise above, my contribution is in the Public Domain; to
> the extent possible under law, I have waived all copyright and related or neighbouring
> rights to this work. Obviously inclusion of works of previous authors is not included in
> the above.
> >
> > --
> > Sent from: http://forum.openscad.org/
> >
> > _______________________________________________
> > OpenSCAD mailing list
> > [hidden email]
> > http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
> > .



--
This email has been checked for viruses by AVG.
https://www.avg.com


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
OpenSCAD Admin - email* me if you need anything, or if I've done something stupid...
* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain;
to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

nophead
The problem is sometimes the list pops up under your mouse, so it gets clicked automatically when you double click to centre or for some reason when I right click to drag and let go.

On Wed, 16 Dec 2020 at 09:58, MichaelAtOz <[hidden email]> wrote:
Note the particular issue was fixed by goldfeather.

> -----Original Message-----
> From: David Slipper [mailto:]
> Sent: Wed, 16 Dec 2020 18:47
> To: MichaelAtOz
> Subject: Re: [OpenSCAD] Odd behaviour in preview ...
>
> Yes, that fixed it !!
>
> Out of curiosity what is "Goldfeather" ???
>
> Many thanks for the prompt action!
> Dave
>
> On 16/12/2020 04:18, MichaelAtOz wrote:
> >> GL Renderer: Intel(R) HD Graphics
> > Sometimes Intel Graphics is a problem.
> > Often enabling Edit/preferences/advanced/force-goldfeather fixes it.
> >
> > Worth a try first.
> >
> >
> >
> > -----
> > OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...
> >
> > * on the Forum, click on my MichaelAtOz label, there is a link to email me.
> >
> > Unless specifically shown otherwise above, my contribution is in the Public Domain; to
> the extent possible under law, I have waived all copyright and related or neighbouring
> rights to this work. Obviously inclusion of works of previous authors is not included in
> the above.
> >
> > --
> > Sent from: http://forum.openscad.org/
> >
> > _______________________________________________
> > OpenSCAD mailing list
> > [hidden email]
> > http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
> > .



--
This email has been checked for viruses by AVG.
https://www.avg.com


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

MichaelAtOz
Administrator
> I then double click the preview image often the image disappears!!

Nophead, THE problem reported in the OP is fixed. Goldfeather Intel. It is
not your issue.

> The problem is sometimes the list pops up

I realise you have reported your problem, but please don't hijack every
report of a 'click' problem.

I have zero issue with double click.

If you want to please reply to:

http://forum.openscad.org/What-is-supposed-to-trigger-the-mouse-click-stack-trace-td30987.html#a31053









-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
OpenSCAD Admin - email* me if you need anything, or if I've done something stupid...
* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain;
to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

nophead
You seem overly sensitive to natural language discussion and seem to want strict segregation of topics. This isn't a github issue and from my perspective not a forum topic. It is just an email discussion where I was replying to Johannes.

On Wed, 16 Dec 2020 at 11:04, MichaelAtOz <[hidden email]> wrote:
> I then double click the preview image often the image disappears!!

Nophead, THE problem reported in the OP is fixed. Goldfeather Intel. It is
not your issue.

> The problem is sometimes the list pops up

I realise you have reported your problem, but please don't hijack every
report of a 'click' problem.

I have zero issue with double click.

If you want to please reply to:

http://forum.openscad.org/What-is-supposed-to-trigger-the-mouse-click-stack-trace-td30987.html#a31053









-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

MichaelAtOz
Administrator

Yes, I'm getting grumpy.

 

But if you didn't...[I did layout an argument with quotes here, but decided no to]

 

I'm just trying to get people to stay on topic.

 

> You seem overly sensitive to natural language discussion 

 

Yes I am aware of the flow, but in this instance with 'goldfeather' & 'intel' & the OP and your history,

I would have thought you would have realised it is not your issue that 'drives me crazy',

and Johannes would not have to remind you it is fixed, but not in a new RC yet.

 

I am sensitive to people positing that their 'issue of note' seems to be reflected in any new post vaguely similar.

It is not you, but seems to be reflective of a general trend.

 

I'm trying to reduce people hitching their peeve du jour to anything new...

 

In this new fake everything world...


Virus-free. www.avg.com

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
OpenSCAD Admin - email* me if you need anything, or if I've done something stupid...
* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain;
to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

MichaelAtOz'
In reply to this post by nophead

...and P.S. for the wider audience,

 

> from my perspective not a forum topic. It is just an email discussion where I was replying to Johannes.

 

Unfortunately, Forum & Mailing-list are inherently linked, 1 to 1.

Email replies are forum posts, and follow the topic.

You can always reply to an individual should you want to discuss separately.

 

I'm just trying to herd the cats...

 


From: Discuss [mailto:[hidden email]] On Behalf Of nop head
Sent: Wed, 16 Dec 2020 22:26
To: OpenSCAD general discussion
Subject: Re: [OpenSCAD] Odd behaviour in preview ...

 

You seem overly sensitive to natural language discussion and seem to want strict segregation of topics. This isn't a github issue and from my perspective not a forum topic. It is just an email discussion where I was replying to Johannes.

 

On Wed, 16 Dec 2020 at 11:04, MichaelAtOz <[hidden email]> wrote:

> I then double click the preview image often the image disappears!!

Nophead, THE problem reported in the OP is fixed. Goldfeather Intel. It is
not your issue.

> The problem is sometimes the list pops up

I realise you have reported your problem, but please don't hijack every
report of a 'click' problem.

I have zero issue with double click.

If you want to please reply to:

http://forum.openscad.org/What-is-supposed-to-trigger-the-mouse-click-stack-trace-td30987.html#a31053









-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


Virus-free. www.avg.com

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

Gadgetman!
In reply to this post by nophead
No, you were replying to EVERYONE who's on the forum and signed up to get emails.  
Please STOP!

Or I'll start telling you all about my adventures in replacing the clutch and flywheel on my car...   
(old car, transverse engine, jackstands and small garage... you really don't want to know more)   

:-(
Trygve

Den 16. desember 2020 kl. 12.26.21 +01.00 skrev nop head <[hidden email]>:
You seem overly sensitive to natural language discussion and seem to want strict segregation of topics. This isn't a github issue and from my perspective not a forum topic. It is just an email discussion where I was replying to Johannes.

On Wed, 16 Dec 2020 at 11:04, MichaelAtOz <[hidden email]> wrote:
> I then double click the preview image often the image disappears!!

Nophead, THE problem reported in the OP is fixed. Goldfeather Intel. It is
not your issue.

> The problem is sometimes the list pops up

I realise you have reported your problem, but please don't hijack every
report of a 'click' problem.

I have zero issue with double click.

If you want to please reply to:










-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--

_______________________________________________
OpenSCAD mailing list
_______________________________________________
OpenSCAD mailing list


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

nophead
So do you see all emails to OpenSCAD general discussion, if so what difference does it make which thread I reply to? Or are you just subscribed to this thread even though you haven't contributed to it before?

On Wed, 16 Dec 2020 at 14:02, <[hidden email]> wrote:
No, you were replying to EVERYONE who's on the forum and signed up to get emails.  
Please STOP!

Or I'll start telling you all about my adventures in replacing the clutch and flywheel on my car...   
(old car, transverse engine, jackstands and small garage... you really don't want to know more)   

:-(
Trygve

Den 16. desember 2020 kl. 12.26.21 +01.00 skrev nop head <[hidden email]>:
You seem overly sensitive to natural language discussion and seem to want strict segregation of topics. This isn't a github issue and from my perspective not a forum topic. It is just an email discussion where I was replying to Johannes.

On Wed, 16 Dec 2020 at 11:04, MichaelAtOz <[hidden email]> wrote:
> I then double click the preview image often the image disappears!!

Nophead, THE problem reported in the OP is fixed. Goldfeather Intel. It is
not your issue.

> The problem is sometimes the list pops up

I realise you have reported your problem, but please don't hijack every
report of a 'click' problem.

I have zero issue with double click.

If you want to please reply to:










-----
OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

* on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--

_______________________________________________
OpenSCAD mailing list
_______________________________________________
OpenSCAD mailing list

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Odd behaviour in preview ...

jon_bondy
 From my perspective, once a thread heads in a direction that does not
interest me, I often just delete subsequent emails without reading them
at all.  And this means that if the topic creeps away from the original,
I might not see something that I would have otherwise read carefully.

Trying to keep threads on topic makes sense to me.

Jon



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org