OPenSCAD exits immediately after start

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

OPenSCAD exits immediately after start

Bojan
Hi,
I have a problem - OpenSCAD presents the splash screen, I click on something
(new design or open recent) and programs simply exits. I can see
openscad.exe process for second in Task Manager, then it dissapears.
If I click on existing design file, nothing is shown, nothing happens.

I updated display drivers, but no change.
Please help!
Bojan



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

kdtop
Has this worked before, but now just stopped working?  What OS are you using?

Kevin

On Tue, Nov 27, 2018 at 4:20 PM Bojan <[hidden email]> wrote:
Hi,
I have a problem - OpenSCAD presents the splash screen, I click on something
(new design or open recent) and programs simply exits. I can see
openscad.exe process for second in Task Manager, then it dissapears.
If I click on existing design file, nothing is shown, nothing happens.

I updated display drivers, but no change.
Please help!
Bojan



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Bojan
In reply to this post by Bojan
Yes, it worked before (W'7 pro), and it works on my other machine at home.
Interesting thing is, recently Repetier host also stopped working (it shows
similar symptoms, this happened quite some time AFTER OpenSCAD stopped),




--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Troberg
Sounds like time for a virus scan.



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Bojan
Not likely...
Computer in question has Sophos Endpoint engine installed regularly, so I
ampretty confident there are no viruses.
However.. could this (or any other) antivirus software be the cause of that
strange behaviour?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

kdtop
Your trust that your virus engine can stop every virus might be a bit optimistic.  However, I would suspect it would be more like some new graphics driver is not working with the engine.  

Are you using the standard release OpenSCAD, or the beta / early versions?  Which every you have, I wonder if you could download the other and see if you have the same problem.  Also, you aren't autoloading an OpenSCAD file, right?  Just trying to open the application by itself.  If you were opening a design that caused a crash (I have had such a file recently), then it might be the design file that is the problem, not the engine itself.

Kevin





On Wed, Nov 28, 2018 at 4:39 PM Bojan <[hidden email]> wrote:
Not likely...
Computer in question has Sophos Endpoint engine installed regularly, so I
ampretty confident there are no viruses.
However.. could this (or any other) antivirus software be the cause of that
strange behaviour?



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Bojan
Hi Kevin,
I am using standard version (2015.03), 64-bit, w'7 Pro.



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

MichaelAtOz
Administrator
See if anything shows in Eventlog?





-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

kdtop
I have not viewed the event log before.  How would I do that?  I.e. where is the file stored?  I'm on OSX

Thanks
Kevin

On Sat, Dec 1, 2018 at 9:22 PM MichaelAtOz <[hidden email]> wrote:
See if anything shows in Eventlog?





-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

kintel
Administrator

> On Dec 2, 2018, at 9:53 PM, Kevin Toppenberg <[hidden email]> wrote:
>
> I have not viewed the event log before.  How would I do that?  I.e. where is the file stored?  I'm on OSX
>
This thread is about Bojan's Windows 7 issue. Are you having startup issue on OS X as well?

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Bojan
Event log is below:

Faulting application name: openscad.exe, version: 0.0.0.0, time stamp:
0x564d2b59
Faulting module name: atig6txx.dll, version: 8.14.1.6463, time stamp:
0x56569fdb
Exception code: 0xc0000005
Fault offset: 0x0000000000016def
Faulting process id: 0x318c
Faulting application start time: 0x01d48ababc497b45
Faulting application path: C:\Program Files\OpenSCAD\openscad.exe
Faulting module path: C:\windows\system32\atig6txx.dll
Report Id: 180788a5-f6ae-11e8-a103-a0481ca3e182




--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Bojan
Repetier Hos has much more events went wrong:
Application: RepetierHost.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
   at OpenTK.Platform.Windows.Wgl+Arb.ChoosePixelFormat(IntPtr, Int32[],
Single[], Int32, Int32[], Int32 ByRef)
   at OpenTK.Platform.Windows.WinGraphicsMode.ChoosePixelFormatARB(IntPtr,
OpenTK.Graphics.GraphicsMode)
   at
OpenTK.Platform.Windows.WinGraphicsMode.SelectGraphicsMode(OpenTK.Graphics.ColorFormat,
Int32, Int32, Int32, OpenTK.Graphics.ColorFormat, Int32, Boolean)
   at
OpenTK.Platform.Windows.WinGLContext.SetGraphicsModePFD(OpenTK.Platform.Windows.WinGraphicsMode,
OpenTK.Graphics.GraphicsMode, OpenTK.Platform.Windows.WinWindowInfo)
   at
OpenTK.Platform.Windows.WinGLContext..ctor(OpenTK.Graphics.GraphicsMode,
OpenTK.Platform.Windows.WinWindowInfo, OpenTK.Graphics.IGraphicsContext,
Int32, Int32, OpenTK.Graphics.GraphicsContextFlags)
   at
OpenTK.Platform.Windows.WinFactory.CreateGLContext(OpenTK.Graphics.GraphicsMode,
OpenTK.Platform.IWindowInfo, OpenTK.Graphics.IGraphicsContext, Boolean,
Int32, Int32, OpenTK.Graphics.GraphicsContextFlags)
   at OpenTK.Graphics.GraphicsContext..ctor(OpenTK.Graphics.GraphicsMode,
OpenTK.Platform.IWindowInfo, Int32, Int32,
OpenTK.Graphics.GraphicsContextFlags)
   at OpenTK.WinGLControl.CreateContext(Int32, Int32,
OpenTK.Graphics.GraphicsContextFlags)
   at OpenTK.GLControl.OnHandleCreated(System.EventArgs)
   at System.Windows.Forms.Control.WmCreate(System.Windows.Forms.Message
ByRef)
   at System.Windows.Forms.Control.WndProc(System.Windows.Forms.Message
ByRef)
   at System.Windows.Forms.UserControl.WndProc(System.Windows.Forms.Message
ByRef)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr,
IntPtr)

Faulting application name: RepetierHost.exe, version: 2.1.3.0, time stamp:
0x5b474e94
Faulting module name: atig6txx.dll, version: 8.14.1.6463, time stamp:
0x56569fdb
Exception code: 0xc0000005
Fault offset: 0x0000000000016def
Faulting process id: 0x6410
Faulting application start time: 0x01d48ac1258a01cd
Faulting application path: C:\Program Files\Repetier-Host\RepetierHost.exe
Faulting module path: C:\windows\system32\atig6txx.dll
Report Id: 6a3cdbdd-f6b4-11e8-a103-a0481ca3e182


Faulting application name: RepetierHost.exe, version: 2.1.3.0, time stamp:
0x5b474e94
Faulting module name: atig6txx.dll, version: 8.14.1.6463, time stamp:
0x56569fdb
Exception code: 0xc000041d
Fault offset: 0x0000000000016def
Faulting process id: 0x6410
Faulting application start time: 0x01d48ac1258a01cd
Faulting application path: C:\Program Files\Repetier-Host\RepetierHost.exe
Faulting module path: C:\windows\system32\atig6txx.dll
Report Id: 6e601fbd-f6b4-11e8-a103-a0481ca3e182





--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

kintel
Administrator
In reply to this post by Bojan
Looks like your ATI GPU drivers crashed.
I would recommend looking for a driver update. GPU drivers should never crash.

This is a similar issue: https://github.com/openscad/openscad/issues/2388

 -Marius

> On Dec 2, 2018, at 11:31 PM, Bojan <[hidden email]> wrote:
>
> Event log is below:
>
> Faulting application name: openscad.exe, version: 0.0.0.0, time stamp:
> 0x564d2b59
> Faulting module name: atig6txx.dll, version: 8.14.1.6463, time stamp:
> 0x56569fdb
> Exception code: 0xc0000005
> Fault offset: 0x0000000000016def
> Faulting process id: 0x318c
> Faulting application start time: 0x01d48ababc497b45
> Faulting application path: C:\Program Files\OpenSCAD\openscad.exe
> Faulting module path: C:\windows\system32\atig6txx.dll
> Report Id: 180788a5-f6ae-11e8-a103-a0481ca3e182
>
>
>
>
> --
> Sent from: http://forum.openscad.org/
>
> _______________________________________________
> OpenSCAD mailing list
> [hidden email]
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Bojan
In reply to this post by Bojan
I found th eprevious version of previously mentioned  atig6txx.dll file..
When I restored it, nox the eror is elsewhere:

Faulting application name: openscad.exe, version: 0.0.0.0, time stamp:
0x564d2b59
Faulting module name: atio6axx.dll, version: 6.14.10.13411, time stamp:
0x5656a648
Exception code: 0xc0000005
Fault offset: 0x0000000001083565
Faulting process id: 0x4f18
Faulting application start time: 0x01d48ac38d5fc005
Faulting application path: C:\Program Files\OpenSCAD\openscad.exe
Faulting module path: C:\windows\system32\atio6axx.dll
Report Id: cc82cde5-f6b6-11e8-a103-a0481ca3e182

Obviously, OpenSCAD doesn't liike newer system files (from 2016 onwards?)



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

kintel
Administrator
> On Dec 2, 2018, at 11:53 PM, Bojan <[hidden email]> wrote:
>
> I found th eprevious version of previously mentioned  atig6txx.dll file..
> When I restored it, nox the eror is elsewhere:
[...]
> Faulting module path: C:\windows\system32\atio6axx.dll

It’s still the ATI drivers that crashes.

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

kdtop
In reply to this post by kintel
I'm not having problems, but I would like to know where the event log is on OS X for future reference.

Thanks


On Sun, Dec 2, 2018 at 10:25 PM Marius Kintel <[hidden email]> wrote:

> On Dec 2, 2018, at 9:53 PM, Kevin Toppenberg <[hidden email]> wrote:
>
> I have not viewed the event log before.  How would I do that?  I.e. where is the file stored?  I'm on OSX
>
This thread is about Bojan's Windows 7 issue. Are you having startup issue on OS X as well?

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: OPenSCAD exits immediately after start

Bojan
In reply to this post by kintel
I updated both ATI and Intel graphic drivers, but no joy, both applications
still crash.
Forgot to mention, system doesn't find any webcam either (not a big problem
for me, though)



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org