MSY2 build no longer works

classic Classic list List threaded Threaded
21 messages Options
12
Reply | Threaded
Open this post in threaded view
|

MSY2 build no longer works

nophead
How does one add the double-conversion package to MSYS2?

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
tp3
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

tp3
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

thehans
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
I have already done that. It updated a shed load of stuff and used another 5GB of disk space!

 pacman -Syu
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do



On Sat, 16 Feb 2019 at 00:13, Hans L <[hidden email]> wrote:
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
I noticed that when Appveyor runs the same script it gets different versions of various packages. Why would that be? Is it simply that MSYS2 has changed since the last OpenSCAD commit? 

On Sat, 16 Feb 2019 at 08:02, nop head <[hidden email]> wrote:
I have already done that. It updated a shed load of stuff and used another 5GB of disk space!

 pacman -Syu
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do



On Sat, 16 Feb 2019 at 00:13, Hans L <[hidden email]> wrote:
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
I followed the advice here: https://github.com/Alexpux/MINGW-packages/issues/4982#issuecomment-464315408 and downloaded it manually.

I now get as far as:

src/handle_dep.cc
In file included from src/printutils.h:8,
                 from src/handle_dep.cc:2:
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp: In function 'const char* boost::system::detail::unknown_message_win32(int, char*, std::size_t)':
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: error: 'libintl_snprintf' is not a member of 'std'
     std::snprintf( buffer, len, "Unknown error (%d)", ev );
          ^~~~~~~~
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: note: suggested alternative:
C:/msys64/mingw64/include/libintl.h:374:12: note:   'libintl_snprintf'
 extern int snprintf (char *, size_t, const char *, ...);
            ^~~~~~~~


On Sat, 16 Feb 2019 at 08:23, nop head <[hidden email]> wrote:
I noticed that when Appveyor runs the same script it gets different versions of various packages. Why would that be? Is it simply that MSYS2 has changed since the last OpenSCAD commit? 

On Sat, 16 Feb 2019 at 08:02, nop head <[hidden email]> wrote:
I have already done that. It updated a shed load of stuff and used another 5GB of disk space!

 pacman -Syu
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do



On Sat, 16 Feb 2019 at 00:13, Hans L <[hidden email]> wrote:
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
I patched boost by removing the std prefix and it now compiles. Lots of warnings about operators as you mentioned before. Also C:/msys64/mingw64/include/boost/pending/integer_log2.hpp:7:59: note: #pragma message: This header is deprecated. Use <boost/integer/integer_log2.hpp> instead.
 BOOST_HEADER_DEPRECATED("<boost/integer/integer_log2.hpp>");

So it looks like I am using a later version of boost.

On Sat, 16 Feb 2019 at 09:14, nop head <[hidden email]> wrote:
I followed the advice here: https://github.com/Alexpux/MINGW-packages/issues/4982#issuecomment-464315408 and downloaded it manually.

I now get as far as:

src/handle_dep.cc
In file included from src/printutils.h:8,
                 from src/handle_dep.cc:2:
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp: In function 'const char* boost::system::detail::unknown_message_win32(int, char*, std::size_t)':
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: error: 'libintl_snprintf' is not a member of 'std'
     std::snprintf( buffer, len, "Unknown error (%d)", ev );
          ^~~~~~~~
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: note: suggested alternative:
C:/msys64/mingw64/include/libintl.h:374:12: note:   'libintl_snprintf'
 extern int snprintf (char *, size_t, const char *, ...);
            ^~~~~~~~


On Sat, 16 Feb 2019 at 08:23, nop head <[hidden email]> wrote:
I noticed that when Appveyor runs the same script it gets different versions of various packages. Why would that be? Is it simply that MSYS2 has changed since the last OpenSCAD commit? 

On Sat, 16 Feb 2019 at 08:02, nop head <[hidden email]> wrote:
I have already done that. It updated a shed load of stuff and used another 5GB of disk space!

 pacman -Syu
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do



On Sat, 16 Feb 2019 at 00:13, Hans L <[hidden email]> wrote:
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
Well it compiles and links but immediately segfaults. I made a debug version and that segfaults more slowly. I have never needed to resort to gdb before but here is a stacktrace

Starting program: C:\msys64\home\ChrisP\openscad\debug\openscad.exe
[New Thread 10688.0x2310]

Program received signal SIGSEGV, Segmentation fault.
0x000000001c58fff0 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libstdc++-6.dll
(gdb) bt
#0  0x000000001c58fff0 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libstdc++-6.dll
#1  0x000000006445df14 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#2  0x000000006444ba5e in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#3  0x000000006444bb4f in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#4  0x0000000064448b3b in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#5  0x0000000064448189 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#6  0x00000000004e27ff in qMain (argc=<optimized out>,
    argv=argv@entry=0x4fd9a2d0)
    at C:/msys64/mingw64/include/boost/function/function_base.hpp:395
#7  0x0000000000583112 in WinMain () at qtmain_win.cpp:104
#8  0x00000000007dabc2 in main (flags=<optimized out>,
    cmdline=<optimized out>, inst=<optimized out>)
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crt0_c.c:18
#9  0x00000000004013a5 in __tmainCRTStartup ()
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:339
#10 0x00000000004014db in WinMainCRTStartup ()
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:195

It seems to crash in QT calling boost.

 msys2-install-dependencies.sh seems to just get the latest of everything. Don't other builds specify compatible versions?


On Sat, 16 Feb 2019 at 09:48, nop head <[hidden email]> wrote:
I patched boost by removing the std prefix and it now compiles. Lots of warnings about operators as you mentioned before. Also C:/msys64/mingw64/include/boost/pending/integer_log2.hpp:7:59: note: #pragma message: This header is deprecated. Use <boost/integer/integer_log2.hpp> instead.
 BOOST_HEADER_DEPRECATED("<boost/integer/integer_log2.hpp>");

So it looks like I am using a later version of boost.

On Sat, 16 Feb 2019 at 09:14, nop head <[hidden email]> wrote:
I followed the advice here: https://github.com/Alexpux/MINGW-packages/issues/4982#issuecomment-464315408 and downloaded it manually.

I now get as far as:

src/handle_dep.cc
In file included from src/printutils.h:8,
                 from src/handle_dep.cc:2:
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp: In function 'const char* boost::system::detail::unknown_message_win32(int, char*, std::size_t)':
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: error: 'libintl_snprintf' is not a member of 'std'
     std::snprintf( buffer, len, "Unknown error (%d)", ev );
          ^~~~~~~~
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: note: suggested alternative:
C:/msys64/mingw64/include/libintl.h:374:12: note:   'libintl_snprintf'
 extern int snprintf (char *, size_t, const char *, ...);
            ^~~~~~~~


On Sat, 16 Feb 2019 at 08:23, nop head <[hidden email]> wrote:
I noticed that when Appveyor runs the same script it gets different versions of various packages. Why would that be? Is it simply that MSYS2 has changed since the last OpenSCAD commit? 

On Sat, 16 Feb 2019 at 08:02, nop head <[hidden email]> wrote:
I have already done that. It updated a shed load of stuff and used another 5GB of disk space!

 pacman -Syu
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do



On Sat, 16 Feb 2019 at 00:13, Hans L <[hidden email]> wrote:
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
I found that the AppVeyor build gets a different list of packages and in general older versions than when I build it on my system. Why would that be when it runs the same script? What determines the versions?

On Sat, 16 Feb 2019 at 12:09, nop head <[hidden email]> wrote:
Well it compiles and links but immediately segfaults. I made a debug version and that segfaults more slowly. I have never needed to resort to gdb before but here is a stacktrace

Starting program: C:\msys64\home\ChrisP\openscad\debug\openscad.exe
[New Thread 10688.0x2310]

Program received signal SIGSEGV, Segmentation fault.
0x000000001c58fff0 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libstdc++-6.dll
(gdb) bt
#0  0x000000001c58fff0 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libstdc++-6.dll
#1  0x000000006445df14 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#2  0x000000006444ba5e in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#3  0x000000006444bb4f in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#4  0x0000000064448b3b in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#5  0x0000000064448189 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#6  0x00000000004e27ff in qMain (argc=<optimized out>,
    argv=argv@entry=0x4fd9a2d0)
    at C:/msys64/mingw64/include/boost/function/function_base.hpp:395
#7  0x0000000000583112 in WinMain () at qtmain_win.cpp:104
#8  0x00000000007dabc2 in main (flags=<optimized out>,
    cmdline=<optimized out>, inst=<optimized out>)
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crt0_c.c:18
#9  0x00000000004013a5 in __tmainCRTStartup ()
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:339
#10 0x00000000004014db in WinMainCRTStartup ()
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:195

It seems to crash in QT calling boost.

 msys2-install-dependencies.sh seems to just get the latest of everything. Don't other builds specify compatible versions?


On Sat, 16 Feb 2019 at 09:48, nop head <[hidden email]> wrote:
I patched boost by removing the std prefix and it now compiles. Lots of warnings about operators as you mentioned before. Also C:/msys64/mingw64/include/boost/pending/integer_log2.hpp:7:59: note: #pragma message: This header is deprecated. Use <boost/integer/integer_log2.hpp> instead.
 BOOST_HEADER_DEPRECATED("<boost/integer/integer_log2.hpp>");

So it looks like I am using a later version of boost.

On Sat, 16 Feb 2019 at 09:14, nop head <[hidden email]> wrote:
I followed the advice here: https://github.com/Alexpux/MINGW-packages/issues/4982#issuecomment-464315408 and downloaded it manually.

I now get as far as:

src/handle_dep.cc
In file included from src/printutils.h:8,
                 from src/handle_dep.cc:2:
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp: In function 'const char* boost::system::detail::unknown_message_win32(int, char*, std::size_t)':
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: error: 'libintl_snprintf' is not a member of 'std'
     std::snprintf( buffer, len, "Unknown error (%d)", ev );
          ^~~~~~~~
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: note: suggested alternative:
C:/msys64/mingw64/include/libintl.h:374:12: note:   'libintl_snprintf'
 extern int snprintf (char *, size_t, const char *, ...);
            ^~~~~~~~


On Sat, 16 Feb 2019 at 08:23, nop head <[hidden email]> wrote:
I noticed that when Appveyor runs the same script it gets different versions of various packages. Why would that be? Is it simply that MSYS2 has changed since the last OpenSCAD commit? 

On Sat, 16 Feb 2019 at 08:02, nop head <[hidden email]> wrote:
I have already done that. It updated a shed load of stuff and used another 5GB of disk space!

 pacman -Syu
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do



On Sat, 16 Feb 2019 at 00:13, Hans L <[hidden email]> wrote:
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
So I had the idea of downloading MSYS2 and not upgrading it. That gave me older versions of the packages but it was missing things like gcc and make. I added those manually but then I am back to it not finding mingw-w64-x86_64-double-conversion.

Does anybody know how the server gets a more recent version of MSYS2 than the freshly downloaded version but not as recent as I get if I upgrade it. Did somebody download it and then upgrade it some time ago?

On Sat, 16 Feb 2019 at 14:49, nop head <[hidden email]> wrote:
I found that the AppVeyor build gets a different list of packages and in general older versions than when I build it on my system. Why would that be when it runs the same script? What determines the versions?

On Sat, 16 Feb 2019 at 12:09, nop head <[hidden email]> wrote:
Well it compiles and links but immediately segfaults. I made a debug version and that segfaults more slowly. I have never needed to resort to gdb before but here is a stacktrace

Starting program: C:\msys64\home\ChrisP\openscad\debug\openscad.exe
[New Thread 10688.0x2310]

Program received signal SIGSEGV, Segmentation fault.
0x000000001c58fff0 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libstdc++-6.dll
(gdb) bt
#0  0x000000001c58fff0 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libstdc++-6.dll
#1  0x000000006445df14 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#2  0x000000006444ba5e in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#3  0x000000006444bb4f in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#4  0x0000000064448b3b in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#5  0x0000000064448189 in ?? ()
   from C:\msys64\home\ChrisP\openscad\libboost_program_options-mt.dll
#6  0x00000000004e27ff in qMain (argc=<optimized out>,
    argv=argv@entry=0x4fd9a2d0)
    at C:/msys64/mingw64/include/boost/function/function_base.hpp:395
#7  0x0000000000583112 in WinMain () at qtmain_win.cpp:104
#8  0x00000000007dabc2 in main (flags=<optimized out>,
    cmdline=<optimized out>, inst=<optimized out>)
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crt0_c.c:18
#9  0x00000000004013a5 in __tmainCRTStartup ()
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:339
#10 0x00000000004014db in WinMainCRTStartup ()
    at C:/repo/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:195

It seems to crash in QT calling boost.

 msys2-install-dependencies.sh seems to just get the latest of everything. Don't other builds specify compatible versions?


On Sat, 16 Feb 2019 at 09:48, nop head <[hidden email]> wrote:
I patched boost by removing the std prefix and it now compiles. Lots of warnings about operators as you mentioned before. Also C:/msys64/mingw64/include/boost/pending/integer_log2.hpp:7:59: note: #pragma message: This header is deprecated. Use <boost/integer/integer_log2.hpp> instead.
 BOOST_HEADER_DEPRECATED("<boost/integer/integer_log2.hpp>");

So it looks like I am using a later version of boost.

On Sat, 16 Feb 2019 at 09:14, nop head <[hidden email]> wrote:
I followed the advice here: https://github.com/Alexpux/MINGW-packages/issues/4982#issuecomment-464315408 and downloaded it manually.

I now get as far as:

src/handle_dep.cc
In file included from src/printutils.h:8,
                 from src/handle_dep.cc:2:
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp: In function 'const char* boost::system::detail::unknown_message_win32(int, char*, std::size_t)':
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: error: 'libintl_snprintf' is not a member of 'std'
     std::snprintf( buffer, len, "Unknown error (%d)", ev );
          ^~~~~~~~
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: note: suggested alternative:
C:/msys64/mingw64/include/libintl.h:374:12: note:   'libintl_snprintf'
 extern int snprintf (char *, size_t, const char *, ...);
            ^~~~~~~~


On Sat, 16 Feb 2019 at 08:23, nop head <[hidden email]> wrote:
I noticed that when Appveyor runs the same script it gets different versions of various packages. Why would that be? Is it simply that MSYS2 has changed since the last OpenSCAD commit? 

On Sat, 16 Feb 2019 at 08:02, nop head <[hidden email]> wrote:
I have already done that. It updated a shed load of stuff and used another 5GB of disk space!

 pacman -Syu
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do



On Sat, 16 Feb 2019 at 00:13, Hans L <[hidden email]> wrote:
How about "pacman -Syu" ?  
And possibly another "pacman -Su" after

From steps 5) and 6) here: https://www.msys2.org/

On Fri, Feb 15, 2019 at 2:51 PM nop head <[hidden email]> wrote:
Well yes it did fix that the double conversion but broke qscintilla. I tried removing it and running the script again but still the same problem.

### 2019-02-15 20:46:40 install mingw-w64-x86_64-qscintilla
resolving dependencies...
looking for conflicting packages...

Packages (1) mingw-w64-x86_64-qscintilla-2.10.8-1

Total Download Size:    8.48 MiB
Total Installed Size:  67.28 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 mingw-w64-x86_64-qscintilla-2.10.8-1-any                                                         8.5 MiB  1450K/s 00:06 [#######################################################################] 100%
(1/1) checking keys in keyring                                                                                           [#######################################################################] 100%
(1/1) checking package integrity                                                                                         [#######################################################################] 100%
:: File /var/cache/pacman/pkg/mingw-w64-x86_64-qscintilla-2.10.8-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (checksum))
Errors occurred, no packages were upgraded.

I also think it has broken bison.

mingw32-make[1]: Entering directory 'C:/msys64/home/ChrisP/openscad'
bison -d -p parser -o objects/parser.cxx --defines=objects/parser.hxx src/parser.y
mingw32-make[1]: *** [Makefile.Release:919: objects/parser.cxx] Error -1073741511
mingw32-make[1]: Leaving directory 'C:/msys64/home/ChrisP/openscad'
mingw32-make: *** [Makefile:34: release] Error 2




On Fri, 15 Feb 2019 at 18:12, nop head <[hidden email]> wrote:
pacman -Sy fixes it.

On Fri, 15 Feb 2019 at 18:09, nop head <[hidden email]> wrote:
Thanks, but it doesn't work on my system. pacman can't find it.

### 2019-02-15 18:00:12 msys2-install-dependencies started
asciidoc 8.6.9-4
autoconf 2.69-3
autoconf2.13 2.13-2
autogen 5.18.4-2
automake-wrapper 10-1
automake1.10 1.10.3-3
automake1.11 1.11.6-3
automake1.12 1.12.6-3
automake1.13 1.13.4-4
automake1.14 1.14.1-3
automake1.15 1.15-2
automake1.6 1.6.3-2
automake1.7 1.7.9-2
automake1.8 1.8.5-3
automake1.9 1.9.6-2
bash 4.4.012-1
bash-completion 2.3-1
bison 3.0.4-1
bsdcpio 3.2.2-2
bsdtar 3.2.2-2
bzip2 1.0.6-2
catgets 1.1-2
coreutils 8.26-1
crypt 1.4-1
cscope 15.8b-1
curl 7.53.1-1
dash 0.5.9.1-1
diffstat 1.58-1
diffutils 3.5-1
dos2unix 7.3.4-1
file 5.30-1
filesystem 2017.02-4
findutils 4.6.0-1
flex 2.6.3-1
gawk 4.1.4-2
gcc-libs 6.3.0-1
gdb 7.11.1-1
gettext-devel 0.19.7-3
git 2.12.1-1
gperf 3.1-1
grep 3.0-1
groff 1.22.3-1
gzip 1.8-1
help2man 1.47.3-1
inetutils 1.9.2-1
info 6.3-1
intltool 0.51.0-2
lemon 3.8.7.0-1
less 481-1
libtool 2.4.6-2
libunrar 5.3.7-1
lndir 1.0.3-1
make 4.2.1-1
man-db 2.7.4-1
mingw-w64-x86_64-boost 1.63.0-1
mingw-w64-x86_64-cgal 4.9.1-1
mingw-w64-x86_64-cmake 3.7.2-2
mingw-w64-x86_64-eigen3 3.3.3-1
mingw-w64-x86_64-gdb 7.12.1-2
mingw-w64-x86_64-glew 2.0.0-1
mingw-w64-x86_64-imagemagick 7.0.5.3-1
mingw-w64-x86_64-libzip 1.2.0-1
mingw-w64-x86_64-mesa 17.0.0-1
mingw-w64-x86_64-opencsg 1.4.0-2
mingw-w64-x86_64-pkg-config 0.29.2-1
mingw-w64-x86_64-qscintilla 2.9-1
mingw-w64-x86_64-qt-creator 4.2.1-2
mintty 1~2.7.3-1
msys2-keyring r9.397a52e-1
msys2-launcher-git 0.3.32.56c2ba7-2
msys2-runtime 2.7.0-1
nano 2.7.5-1
ncurses 6.0.20170121-1
pacman 5.0.1-2
pacman-mirrors 20160112-1
pactoys-git r2.07ca37f-1
patch 2.7.5-1
patchutils 0.3.4-1
pax-git 20140703.2.1.g469552a-1
pkg-config 0.29.2-1
pkgfile 15-1
python 3.4.5-1
python2 2.7.13-1
quilt 0.65-1
rcs 5.9.4-1
rebase 4.4.2-1
scons 2.5.0-1
sed 4.4-2
swig 3.0.10-1
texinfo 6.3-1
texinfo-tex 6.3-1
tftp-hpa 5.2-1
time 1.7-1
ttyrec 1.0.8-1
tzcode 2017.b-1
unrar 5.3.7-1
util-linux 2.26.2-1
which 2.21-2
xmlto 0.0.28-1
### 2019-02-15 18:00:13 install mingw-w64-x86_64-gdb
warning: mingw-w64-x86_64-gdb-7.12.1-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-boost
warning: mingw-w64-x86_64-boost-1.63.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:13 install mingw-w64-x86_64-cgal
warning: mingw-w64-x86_64-cgal-4.9.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-eigen3
warning: mingw-w64-x86_64-eigen3-3.3.3-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-glew
warning: mingw-w64-x86_64-glew-2.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-qscintilla
warning: mingw-w64-x86_64-qscintilla-2.9-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:14 install mingw-w64-x86_64-opencsg
warning: mingw-w64-x86_64-opencsg-1.4.0-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-pkg-config
warning: mingw-w64-x86_64-pkg-config-0.29.2-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-libzip
warning: mingw-w64-x86_64-libzip-1.2.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:15 install mingw-w64-x86_64-cmake
warning: mingw-w64-x86_64-cmake-3.7.2-2 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-mesa
warning: mingw-w64-x86_64-mesa-17.0.0-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:16 install mingw-w64-x86_64-double-conversion
error: target not found: mingw-w64-x86_64-double-conversion
### 2019-02-15 18:00:16 install make
warning: make-4.2.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install bison
warning: bison-3.0.4-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 install git
warning: git-2.12.1-1 is up to date -- skipping there is nothing to do
### 2019-02-15 18:00:17 msys2-install-dependencies finished




On Fri, 15 Feb 2019 at 12:30, Torsten Paul <[hidden email]> wrote:
The package seems to be mingw-w64-x86_64-double-conversion.


This script is used for installing/updating MSYS2 for the AppVeyor CI builds.

ciao,
  Torsten.

Am 15.02.2019 um 12:35 schrieb nop head <[hidden email]>:

How does one add the double-conversion package to MSYS2?
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

kintel
Administrator
What if you try to fix the first error instead?

In file included from src/printutils.h:8,
                 from src/handle_dep.cc:2:
[...]
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: error: 'libintl_snprintf' is not a member of 'std'

The problem seems to be that libintl #defines snprintf as libintl_snprintf, and boost picks that up but tries to use the std namespace.
..which in included in printutils.h

..so if in printutils.cc, you include boost before printutils.h, perhaps that improves things?

 -Marius



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
I manage to build with a fresh download of MSYS2 without any updates. So generally older versions of everything. So then there is no problem compiling with boost but I still get a segmentation error at startup so I am losing hope of it ever working again. I thought the problem was caused by using later versions of packages but earlier seems just as bad. I have no idea what the problem is. 

I could try with the latest of everything again and try the alternative boost fix. I would have thought one snprint was pretty much the same as another though. I wrote one myself in the 80s, with the same name, long before Microsoft thought of it. sprintf made no sense at all to me, especially on an embedded system.



On Sun, 17 Feb 2019 at 21:04, Marius Kintel <[hidden email]> wrote:
What if you try to fix the first error instead?

In file included from src/printutils.h:8,
                 from src/handle_dep.cc:2:
[...]
C:/msys64/mingw64/include/boost/system/detail/system_category_win32.hpp:52:10: error: 'libintl_snprintf' is not a member of 'std'

The problem seems to be that libintl #defines snprintf as libintl_snprintf, and boost picks that up but tries to use the std namespace.
..which in included in printutils.h

..so if in printutils.cc, you include boost before printutils.h, perhaps that improves things?

 -Marius



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

kintel
Administrator
On Feb 17, 2019, at 18:37, nop head <[hidden email]> wrote:
>
> I could try with the latest of everything again and try the alternative boost fix. I would have thought one snprint was pretty much the same as another though. I wrote one myself in the 80s, with the same name, long before Microsoft thought of it. sprintf made no sense at all to me, especially on an embedded system.
>
I cannot say I know what gettext tries to do, but the error definitely just looks like a name resolution issue.

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

thehans
Can you get a backtrace with debug symbols?
qmake CONFIG+=debug CONFIG+=experimental 

That should add "-g" to CFLAGS/CXXFLAGS  or you can just manually edit those into the top of the generated Makefile
I tend to also manually add "-fno-omit-frame-pointers" to both if debugging a crash, and sometimes replace "-O2" with "-Og" though I'm not sure how much difference those truly make.

Then "make clean" and "make -j8" again (or with your preferred -j value)








On Sun, Feb 17, 2019 at 7:21 PM Marius Kintel <[hidden email]> wrote:
On Feb 17, 2019, at 18:37, nop head <[hidden email]> wrote:
>
> I could try with the latest of everything again and try the alternative boost fix. I would have thought one snprint was pretty much the same as another though. I wrote one myself in the 80s, with the same name, long before Microsoft thought of it. sprintf made no sense at all to me, especially on an embedded system.
>
I cannot say I know what gettext tries to do, but the error definitely just looks like a name resolution issue.

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

nophead
The stake trace above was from a debug build but it didn't show any symbols from Qt where it crashes.

Last time I did make clean it was an infinite loop so l have been removing all the .o files with find.

What is the j parameter?

Since the crash is in boost called by Qt I don't see how it has anything to do with openscad.



On Mon, 18 Feb 2019, 02:06 Hans L <[hidden email] wrote:
Can you get a backtrace with debug symbols?
qmake CONFIG+=debug CONFIG+=experimental 

That should add "-g" to CFLAGS/CXXFLAGS  or you can just manually edit those into the top of the generated Makefile
I tend to also manually add "-fno-omit-frame-pointers" to both if debugging a crash, and sometimes replace "-O2" with "-Og" though I'm not sure how much difference those truly make.

Then "make clean" and "make -j8" again (or with your preferred -j value)








On Sun, Feb 17, 2019 at 7:21 PM Marius Kintel <[hidden email]> wrote:
On Feb 17, 2019, at 18:37, nop head <[hidden email]> wrote:
>
> I could try with the latest of everything again and try the alternative boost fix. I would have thought one snprint was pretty much the same as another though. I wrote one myself in the 80s, with the same name, long before Microsoft thought of it. sprintf made no sense at all to me, especially on an embedded system.
>
I cannot say I know what gettext tries to do, but the error definitely just looks like a name resolution issue.

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
rew
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

rew
On Mon, Feb 18, 2019 at 11:15:25AM +0000, nop head wrote:
> The stake trace above was from a debug build but it didn't show any symbols
> from Qt where it crashes.
>
> Last time I did make clean it was an infinite loop so l have been removing
> all the .o files with find.
>
> What is the j parameter?

I use
  -j 5

to instruct make to try to keep 5 compile-jobs running at the same
time. I use "one more than the number of Cores". This to try to have a
CPU-consuming job ready when one of the compile jobs needs something
from the disk. Most others recommend using the numer-of-cores without
incrementing by one like I do.

Without it will work just fine, but in my case the -j 5 often reduces
the build time by a factor of 4 (as my computer has 4 cores).

        Roger.

--
** [hidden email] ** https://www.BitWizard.nl/ ** +31-15-2049110 **
**    Delftechpark 11 2628 XJ  Delft, The Netherlands.  KVK: 27239233    **
The plan was simple, like my brother-in-law Phil. But unlike
Phil, this plan just might work.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: MSY2 build no longer works

kintel
Administrator
In reply to this post by nophead
> On Feb 18, 2019, at 06:15, nop head <[hidden email]> wrote:
>
> Since the crash is in boost called by Qt I don't see how it has anything to do with openscad.
>
Qt doesn't use boost, so this is most likely cmd-line handling in openscad.cc

Perhaps Windows passes some extra cmd-line argument to the process, triggering a failure to validate arguments on our side?
That exact issue has happened on Mac before..

 -Marius
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
12