How to chage the language?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

How to chage the language?

Peter Falke
I installed OpenSCAD recently on a new computer and now everything is in German.
Does anybody know how I can revert back to English?

Thanks

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
tp3
Reply | Threaded
Open this post in threaded view
|

Re: How to chage the language?

tp3
On 11/17/2015 09:45 PM, Peter Falke wrote:
> I installed OpenSCAD recently on a new computer and now everything
> is in German.
> Does anybody know how I can revert back to English?
>
Localization can be disabled in Preferences / Advanced.

ciao,
  Torsten.


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: How to chage the language?

kintel
Administrator
> On Nov 17, 2015, at 15:56 PM, Torsten Paul <[hidden email]> wrote:
>>
> Localization can be disabled in Preferences / Advanced.
>
Also, we should pick up your preferred localization from the OS. If that doesn’t work, I think it would be considered a bug.

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: How to chage the language?

Peter Falke
Thanks, Torsten, I found it and changes it back.

Marius, it did pick up the localization from the OS (win 7). It just wasn't what I like for Openscad.

2015-11-18 4:58 GMT+01:00 Marius Kintel <[hidden email]>:
> On Nov 17, 2015, at 15:56 PM, Torsten Paul <[hidden email]> wrote:
>>
> Localization can be disabled in Preferences / Advanced.
>
Also, we should pick up your preferred localization from the OS. If that doesn’t work, I think it would be considered a bug.

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: How to chage the language?

computer.ios@saintannsny.org
In reply to this post by Peter Falke
If OpenSCAD (on a mac) is in a language you don't speak, here's how to find its preference and fix it.

--Use first main menu (next to the apple, should be "OpenSCAD").
--Choose "Preferences" (third menu item, and menu was in English on my mac).
--In Preferences window choose 4th tab, (which has gear icon, says "Advanced" if menus are in English).
--Turn Off the last checkbox [ ] (which says "Enable user interface localization…" if menus are in English).
--Restart OpenSCAD.

My mac is normally in English but had Russian as a second language, and OpenScad opened in Russian, which I don't read well enough to find the preferences.
My cure was to remove Russian from "SystemPreferences:Language&Region:PreferredLanguages:" and then openSCAD was in English next time. Then I could find the relevant preference, write this note for you all. I'm not sure whether windows computers will have exactly the same menu layout.

best regards,
Mike
Reply | Threaded
Open this post in threaded view
|

Re: How to chage the language?

mprogers
> On Jan 10, 2017, at 2:30 PM, [hidden email] wrote:
>
> If OpenSCAD (on a mac) is in a language you don't speak, here's how to find
> its preference and fix it.
>
> --Use first main menu (next to the apple, should be "OpenSCAD").
> --Choose "Preferences" (third menu item, and menu was in English on my mac).
> --In Preferences window choose 4th tab, (which has gear icon, says
> "Advanced" if menus are in English).
> --Turn Off the last checkbox [ ] (which says "Enable user interface
> localization…" if menus are in English).
> --Restart OpenSCAD.

Worked perfectly, thank you!

Michael
_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Confused as how a this could happen

louijp
In reply to this post by computer.ios@saintannsny.org
Thanks Mike.
My MacBook had french as a second language, and OpenSCAD was now starting in French which wasn’t too bad as I am a native French living in the US.

But I was frustrated by the fact that I wasn’t able to understand why things changed with the release of OS X Sierra. I created a work around by creating an alias from the OS X app, but that was launching two terminal windows before launching the app, so it wasn’t optimum.

Now everything is back to normal, so I am a happy user again.

Jean-Paul
N1JPL




> On Jan 10, 2017, at 4:26 PM, MichaelAtOz <[hidden email]> wrote:
>
> If OpenSCAD (on a mac) is in a language you don't speak, here's how to find
> its preference and fix it.
>
> --Use first main menu (next to the apple, should be "OpenSCAD").
> --Choose "Preferences" (third menu item, and menu was in English on my mac).
> --In Preferences window choose 4th tab, (which has gear icon, says
> "Advanced" if menus are in English).
> --Turn Off the last checkbox [ ] (which says "Enable user interface
> localization…" if menus are in English).
> --Restart OpenSCAD.
>
> My mac is normally in English but had Russian as a second language, and
> OpenScad opened in Russian, which I don't read well enough to find the
> preferences.
> My cure was to remove Russian from
> "SystemPreferences:Language&Region:PreferredLanguages:" and then openSCAD
> was in English next time. Then I could find the relevant preference, write
> this note for you all. I'm not sure whether windows computers will have
> exactly the same menu layout.
>
> best regards,
> Mike
>
>
>
> --
> View this message in context: http://forum.openscad.org/How-to-chage-the-language-tp14604p20013.html
> Sent from the OpenSCAD mailing list archive at Nabble.com.
>
> _______________________________________________
> OpenSCAD mailing list
> [hidden email]
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Confused as how a this could happen

clothbot
I “resolved it” by removing French (Canadian) from MacOS then added it back.  Then OpenSCAD used my preferred English as default/startup language.

Andrew.

On Jan 11, 2017, at 3:59 PM, Jean-Paul Louis <[hidden email]> wrote:

Thanks Mike.
My MacBook had french as a second language, and OpenSCAD was now starting in French which wasn’t too bad as I am a native French living in the US.

But I was frustrated by the fact that I wasn’t able to understand why things changed with the release of OS X Sierra. I created a work around by creating an alias from the OS X app, but that was launching two terminal windows before launching the app, so it wasn’t optimum.

Now everything is back to normal, so I am a happy user again.

Jean-Paul
N1JPL




On Jan 10, 2017, at 4:26 PM, MichaelAtOz <[hidden email]> wrote:

If OpenSCAD (on a mac) is in a language you don't speak, here's how to find
its preference and fix it.

--Use first main menu (next to the apple, should be "OpenSCAD").
--Choose "Preferences" (third menu item, and menu was in English on my mac).
--In Preferences window choose 4th tab, (which has gear icon, says
"Advanced" if menus are in English).
--Turn Off the last checkbox [ ] (which says "Enable user interface
localization…" if menus are in English).
--Restart OpenSCAD.

My mac is normally in English but had Russian as a second language, and
OpenScad opened in Russian, which I don't read well enough to find the
preferences.
My cure was to remove Russian from
"SystemPreferences:Language&Region:PreferredLanguages:" and then openSCAD
was in English next time. Then I could find the relevant preference, write
this note for you all. I'm not sure whether windows computers will have
exactly the same menu layout.

best regards,
Mike



--
View this message in context: http://forum.openscad.org/How-to-chage-the-language-tp14604p20013.html
Sent from the OpenSCAD mailing list archive at Nabble.com.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

--

"The future is already here.  It's just not very evenly distributed" -- William Gibson

Me: http://clothbot.com/wiki/




_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org