GUI runs ok, command line crashes

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

GUI runs ok, command line crashes

bobc
I have a project which renders fine in the GUI in a few seconds, but when called from command line it takes a long time then crashes. Are there any known issues that might cause this?

My command line is this:

"C:\Program Files\OpenSCAD\openscad.exe" -o p10034.stl rapman_x-carriage_lm12uu.scad

OpenSCAD 2013.01
Windows 7 32 bit

If I can I will narrow down a smaller testcase which reproduces the fault (or my error!).
Reply | Threaded
Open this post in threaded view
|

Re: GUI runs ok, command line crashes

kintel
Administrator
On 2013-05-27, at 11:25 , bobc wrote:

> I have a project which renders fine in the GUI in a few seconds, but when
> called from command line it takes a long time then crashes. Are there any
> known issues that might cause this?
>
Some ideas:
o Did you try rendering using F6 in the GUI - does it behave similar to the cmd-line
o Could you try monitoring memory usage before it crashes? Is it close to 2GB? If so, try the 64-bit development snapshot (http://www.openscad.org/downloads.html#snapshots)
o The development snapshot also has better Windows cmd-line functionality (use openscad.com)

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://rocklinux.net/mailman/listinfo/openscad
http://openscad.org - https://flattr.com/thing/121566