Export as image no longer works with F5?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Export as image no longer works with F5?

QuackingPlums
Is it intentional that "Export to image" now only works after a render (F6) and not a preview (F5)?

There was weird behaviour in previous versions where I sometimes had to hit F5 several times before the correct image would get exported, but it appears that now (since 2014.11.05 at least) attempting to export an image without rendering with F6 results in an empty scene.
tp3
Reply | Threaded
Open this post in threaded view
|

Re: Export as image no longer works with F5?

tp3
On 01/13/2015 03:50 PM, QuackingPlums wrote:
> Is it intentional that "Export to image" now only works after a render (F6)
> and not a preview (F5)?
>
No, and it does work for me with the latest snapshot (on Linux).

ciao,
   Torsten.



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: Export as image no longer works with F5?

QuackingPlums
Sorry I should have been clearer. I tested with the latest OSX snapshot just before posting - it is doing it with 2015.01.05

Could this be related to an issue I've had with previous versions where if I wanted to export a number of renders using different colours, then OpenSCAD would appear to export the render from the *previous* press of F5?

E.g. my workflow would be:
- set colour("red"), F5, Export to image, call it RedRender.png
- set colour("green"), F5, Export to image, call it GreenRender.png
- set colour("blue"), F5, Export to image, call it BlueRender.png

but when I open up my files I find that RedRender.png would be blank, GreenRender.png would be red, and BlueRender.png would be green, etc. I've learned to get around this by simply saving RedRender.png twice before moving on to the other colours.

Saving twice in this instance doesn't appear to make the render output anything other than a blank PNG.

E.
Reply | Threaded
Open this post in threaded view
|

Re: Export as image no longer works with F5?

QuackingPlums
Actually, ignore my last sentence. I just tried again with a canonical test (50x30 cylinder) and though the first "Export to image" results in a blank PNG, the second attempt (no re-render in-between) results in a correct PNG output.

There must be something in my more complex file that is compounding the issue.

tp3
Reply | Threaded
Open this post in threaded view
|

Re: Export as image no longer works with F5?

tp3
In reply to this post by QuackingPlums
On 01/13/2015 04:54 PM, QuackingPlums wrote:
> Could this be related to an issue I've had with previous versions where if I
> wanted to export a number of renders using different colours, then OpenSCAD
> would appear to export the render from the*previous*  press of F5?
 >
Export Image is basically a screenshot of the current view port. So if
the view port is empty, the PNG will be too.

ciao,
   Torsten.


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-- Torsten
Reply | Threaded
Open this post in threaded view
|

Re: Export as image no longer works with F5?

kintel
Administrator
In reply to this post by QuackingPlums

On Jan 13, 2015, at 10:54 AM, QuackingPlums <[hidden email]> wrote:

> Saving twice in this instance doesn't appear to make the render output
> anything other than a blank PNG.
>
I can reproduce on Mac. Please follow this issue: https://github.com/openscad/openscad/issues/1154

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Export as image no longer works with F5?

kintel
Administrator
In reply to this post by QuackingPlums
Btw., this was fixed some days ago..

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Export as image no longer works with F5?

QuackingPlums
Thank Marius, I saw the commit. I'll update and test when I have a moment.