ERROR: CGAL error in CGALUtils::applyUnion3D: CGAL ERROR: assertion violation!

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ERROR: CGAL error in CGALUtils::applyUnion3D: CGAL ERROR: assertion violation!

nophead
I have started getting this error since installing the new release when generating pngs from the command line but it seems to carry on and generate the image. Not sure if ti is related to the release 

Looking at the same preview in the GUI I don't get an error, so I have no idea how to find it as the picture is my entire assembly.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: CGAL error in CGALUtils::applyUnion3D: CGAL ERROR: assertion violation!

nophead
Actually I was accidentally doing a union with an imported STL made by OpenSCAD that had degenerate triangles due to a misplaced curly bracket. There is a bug though because the ERROR does not set the exit status so I had missed it.

On Mon, 8 Feb 2021 at 15:22, nop head <[hidden email]> wrote:
I have started getting this error since installing the new release when generating pngs from the command line but it seems to carry on and generate the image. Not sure if ti is related to the release 

Looking at the same preview in the GUI I don't get an error, so I have no idea how to find it as the picture is my entire assembly.

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org