Crash on F6 and missing preview/render window

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Crash on F6 and missing preview/render window

tangerine0469
Hi all,

I have a few issues that crept up all of a sudden with my PC running
OpenScad.

This started off randomly when I opened the program after work the other day
after having spent and evening prior working on a project. The app loads the
editor, the console and the code from the selected project but no
render/preview window. Hitting F5 or the option in the menu appears to run
fine in the console but thats as far as it gets. Hitting F6 however stats
the render and gets to approx 475/1000 before the app closes and drops an
error in my event viewer which doesn't show much of anything:

Faulting application name: openscad.exe, version: 0.0.0.0, time stamp:
0x564d2b59
Faulting module name: openscad.exe, version: 0.0.0.0, time stamp: 0x564d2b59
Exception code: 0x40000015
Fault offset: 0x0000000000f9801a
Faulting process id: 0x3258
Faulting application start time: 0x01d44d3fbf0520be
Faulting application path:
C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2\openscad.exe
Faulting module path:
C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2\openscad.exe
Report Id: 2a5e9b25-c4a5-4ce5-a059-2940edba4ee2
Faulting package full name:
Faulting package-relative application ID:


I have tried the whole uninstall>reboot>install routine many times and even
using the binary, not the installer.  Falling back on my Sysadmin methods I
decided to try and run the app from the CLI as my user and as admin and this
is where I am finally seeing some details that I need some insight on.
Running the app from the CLI I get this after opening a new or existing
project:
GLEW Error: Missing GL version

I know that GL is up to date and my drivers have been both reinstalled and
then updated when the results were the same. Render shows this in the CLI
(the first line is on open of the .scad file, the rest on crash):

GLEW Error: Missing GL version
CGAL error: assertion violation!
Expression : object_list_
File       : ../src/OGL_helper.h
Line       : 571
Explanation:
Refer to the bug-reporting instructions at
http://www.cgal.org/bug_report.html


I tried to open Help>Library Info and get this:

GLEW Error: Missing GL version
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_M_construct null not valid

Finally I tried to run "openscad.exe --info" and got this and the app failed
to load at all:

C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2>openscad.exe
--info

C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2>OpenSCAD
Version: 2015.03-2
System information: Windows 8 (v6.2.0.0) 8 CPUs 15.90 GB RAM
Compiler: GCC "5.2.0" 64bit
Boost version: 1_57
Eigen version: 3.2.5
CGAL version, kernels: 4.5, Cartesian<Gmpq>, Extended_cartesian<Gmpq>, Epeck
OpenCSG version: OpenCSG 1.4.0
Qt version: 5.5.1
QScintilla version: 2.8.4
MingW build: MingW64
GLib version: 2.44.1
Application Path:
C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2
Documents Path: C:\Users\John\Documents
Resource Path:
C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2
User Library Path: C:/Users/John/Documents/OpenSCAD/libraries
User Config Path: C:\Users\John\AppData\Local/OpenSCAD
Backup Path: C:/Users/John/Documents/OpenSCAD/backups
OPENSCADPATH: <not set>
OpenSCAD library path:
  C:/Users/John/Documents/OpenSCAD/libraries
 
C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2\libraries

OPENSCAD_FONT_PATH: <not set>
OpenSCAD font path:


OpenGL Program Validation results:
Validation successful.
GLEW version: 1.12.0
OpenGL Version: 4.5.13539 Compatibility Profile Context 24.20.13017.1009
GL Renderer: Radeon RX 580 Series
GL Vendor: ATI Technologies Inc.
RGBA(8888), depth(24), stencil(8)
GL_ARB_framebuffer_object: yes
GL_EXT_framebuffer_object: yes
GL_EXT_packed_depth_stencil: yes
GL context creator: WGL
PNG generator: lodepng
OS info: Microsoft(TM) Windows(TM) 6 2 9200 0x24bd0e4 amd64
Machine: 8664


Sorry for the long post, my sysadmin work taught me that there is no such
thing as too much information.



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

thehans
Do you get the same errors with a development snapshot of OpenSCAD?
http://www.openscad.org/downloads.html#snapshots


On Sat, Sep 15, 2018 at 5:53 PM tangerine0469
<[hidden email]> wrote:

>
> Hi all,
>
> I have a few issues that crept up all of a sudden with my PC running
> OpenScad.
>
> This started off randomly when I opened the program after work the other day
> after having spent and evening prior working on a project. The app loads the
> editor, the console and the code from the selected project but no
> render/preview window. Hitting F5 or the option in the menu appears to run
> fine in the console but thats as far as it gets. Hitting F6 however stats
> the render and gets to approx 475/1000 before the app closes and drops an
> error in my event viewer which doesn't show much of anything:
>
> Faulting application name: openscad.exe, version: 0.0.0.0, time stamp:
> 0x564d2b59
> Faulting module name: openscad.exe, version: 0.0.0.0, time stamp: 0x564d2b59
> Exception code: 0x40000015
> Fault offset: 0x0000000000f9801a
> Faulting process id: 0x3258
> Faulting application start time: 0x01d44d3fbf0520be
> Faulting application path:
> C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2\openscad.exe
> Faulting module path:
> C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2\openscad.exe
> Report Id: 2a5e9b25-c4a5-4ce5-a059-2940edba4ee2
> Faulting package full name:
> Faulting package-relative application ID:
>
>
> I have tried the whole uninstall>reboot>install routine many times and even
> using the binary, not the installer.  Falling back on my Sysadmin methods I
> decided to try and run the app from the CLI as my user and as admin and this
> is where I am finally seeing some details that I need some insight on.
> Running the app from the CLI I get this after opening a new or existing
> project:
> GLEW Error: Missing GL version
>
> I know that GL is up to date and my drivers have been both reinstalled and
> then updated when the results were the same. Render shows this in the CLI
> (the first line is on open of the .scad file, the rest on crash):
>
> GLEW Error: Missing GL version
> CGAL error: assertion violation!
> Expression : object_list_
> File       : ../src/OGL_helper.h
> Line       : 571
> Explanation:
> Refer to the bug-reporting instructions at
> http://www.cgal.org/bug_report.html
>
>
> I tried to open Help>Library Info and get this:
>
> GLEW Error: Missing GL version
> terminate called after throwing an instance of 'std::logic_error'
>   what():  basic_string::_M_construct null not valid
>
> Finally I tried to run "openscad.exe --info" and got this and the app failed
> to load at all:
>
> C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2>openscad.exe
> --info
>
> C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2>OpenSCAD
> Version: 2015.03-2
> System information: Windows 8 (v6.2.0.0) 8 CPUs 15.90 GB RAM
> Compiler: GCC "5.2.0" 64bit
> Boost version: 1_57
> Eigen version: 3.2.5
> CGAL version, kernels: 4.5, Cartesian<Gmpq>, Extended_cartesian<Gmpq>, Epeck
> OpenCSG version: OpenCSG 1.4.0
> Qt version: 5.5.1
> QScintilla version: 2.8.4
> MingW build: MingW64
> GLib version: 2.44.1
> Application Path:
> C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2
> Documents Path: C:\Users\John\Documents
> Resource Path:
> C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2
> User Library Path: C:/Users/John/Documents/OpenSCAD/libraries
> User Config Path: C:\Users\John\AppData\Local/OpenSCAD
> Backup Path: C:/Users/John/Documents/OpenSCAD/backups
> OPENSCADPATH: <not set>
> OpenSCAD library path:
>   C:/Users/John/Documents/OpenSCAD/libraries
>
> C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2\libraries
>
> OPENSCAD_FONT_PATH: <not set>
> OpenSCAD font path:
>
>
> OpenGL Program Validation results:
> Validation successful.
> GLEW version: 1.12.0
> OpenGL Version: 4.5.13539 Compatibility Profile Context 24.20.13017.1009
> GL Renderer: Radeon RX 580 Series
> GL Vendor: ATI Technologies Inc.
> RGBA(8888), depth(24), stencil(8)
> GL_ARB_framebuffer_object: yes
> GL_EXT_framebuffer_object: yes
> GL_EXT_packed_depth_stencil: yes
> GL context creator: WGL
> PNG generator: lodepng
> OS info: Microsoft(TM) Windows(TM) 6 2 9200 0x24bd0e4 amd64
> Machine: 8664
>
>
> Sorry for the long post, my sysadmin work taught me that there is no such
> thing as too much information.
>
>
>
> --
> Sent from: http://forum.openscad.org/
>
> _______________________________________________
> OpenSCAD mailing list
> [hidden email]
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

MichaelAtOz
Administrator
In reply to this post by tangerine0469
Is your project doing any import()'s?
What happens with just:

  cube();
  sphere();





-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

tangerine0469
In reply to this post by tangerine0469



thehans wrote
> Do you get the same errors with a development snapshot of OpenSCAD?
> http://www.openscad.org/downloads.html#snapshots


Using the Snapshot I get the following when doing an F6:

C:\Users\John\Downloads\OpenSCAD-2018.09.05-x86-64\openscad-2018.09.05>GLEW
Error: Missing GL version
CGAL error: assertion violation!
Expression : object_list_
File       : ../src/ext/CGAL/OGL_helper.h
Line       : 572
Explanation:
Refer to the bug-reporting instructions at
http://www.cgal.org/bug_report.html


Trying to get the info from Help>Library Information I get the following:

A critical Error was caught. The application may have become unstable:
basic_string::_M_construct null not valid




MichaelAtOz wrote
> Is your project doing any import()'s?
> What happens with just:
>
>   cube();
>   sphere();



When I try the basic shapes I get this:

cube(20);
sphere(20);

Console after F5:

Saved backup file:
C:/Users/John/Documents/OpenSCAD/backups/unsaved-backup-lHOvRHJL.scad
Compiling design (CSG Tree generation)...
Compiling design (CSG Products generation)...
Geometries in cache: 2
Geometry cache size in bytes: 62800
CGAL Polyhedrons in cache: 0
CGAL cache size in bytes: 0
Compiling design (CSG Products normalization)...
Normalized CSG tree has 2 elements
Compile and preview finished.
Total rendering time: 0 hours, 0 minutes, 0 seconds

F6

C:\Users\John\Downloads\OpenSCAD-2018.09.05-x86-64\openscad-2018.09.05>GLEW
Error: Missing GL version
CGAL error: assertion violation!
Expression : object_list_
File       : ../src/ext/CGAL/OGL_helper.h
Line       : 572
Explanation:
Refer to the bug-reporting instructions at
http://www.cgal.org/bug_report.html



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

MichaelAtOz
Administrator
In reply to this post by tangerine0469
> but no render/preview window

Chicken/Egg, is the lack of the window causing the error, or an OpenGL error
prevent the window opening...hmm

It was working and you haven't upgraded the graphics card?
It has the taste of a graphics driver issue...



-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

tangerine0469
MichaelAtOz wrote
>> but no render/preview window
>
> Chicken/Egg, is the lack of the window causing the error, or an OpenGL
> error
> prevent the window opening...hmm
>
> It was working and you haven't upgraded the graphics card?
> It has the taste of a graphics driver issue...

That's the thing, There were zero changes made to the machine. I lock mine
down from auto-updates due to watching the horrors they cause at the data
center I do advanced implementations at. Not a domain controlled computer
but I have picked the auto updates clean through LGPO, services and
scheduled tasks  lol.

I was feeling the same thing so thats when I decided to try and update them,
reboot, test. When that failed I removed entirely and rolled back to the
known good ones and no dice. I have two newish (6 month old or less) rx
580's, not running any advanced features like Eyenfinity or crossfire, no
overclocking, not coin mining,  etc. I will admit that I am more of an
OS/Hardware/Server Software flavor of IT guy and GPU drivers are not on my
nice list but to literally break overnight like that is beyond strange.

I attached a copy of my code for the part I was working on. You can ignore
the commented out render() as that was a test I ran to see if it could do so
without crashing the app. Adding render() to the part certainly locks it up
while it does so but it doesn't crash nor fix the issue so I commented it
out.

This is still very clearly a work in progress so ignore the ugly
code/appearance.

For reference my machine is this:

FX-8350 CPU
16GB ram
dual rx580
Liquid loop CPU cooler
Raid 10 primary HDD using Perc h700 with BBU and 1GB Memory
4 monitors

All tests were run with nothing else running outside of normal OS services
for maximum resource availability
shield.scad <http://forum.openscad.org/file/t2341/shield.scad>  



--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

MichaelAtOz
Administrator
That previews & renders on my W7/64 system with 2015.03-2/64.

F6:

Saved backup file:
C:/Users/MeB/Documents/OpenSCAD/backups/unsaved-backup-gqHp8060.scad
Compiling design (CSG Tree generation)...
Rendering Polygon Mesh using CGAL...
Geometries in cache: 2255
Geometry cache size in bytes: 849072
CGAL Polyhedrons in cache: 8
CGAL cache size in bytes: 45322736
Total rendering time: 0 hours, 4 minutes, 41 seconds
   Top level object is a 3D object:
   Simple:         no
   Vertices:     6460
   Halfedges:   19380
   Edges:        9690
   Halffacets:   6472
   Facets:       3236
   Volumes:         2
WARNING: Object may not be a valid 2-manifold and may need repair!
Rendering finished.


Same on a recent development snapshot.





-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

MichaelAtOz
Administrator
> OpenGL Version: 4.5.13539 *Compatibility Profile Context 24.20.13017.1009 *

Hmm,  In GL 3.3 Core specification, Appendix E, it is said that a GL context
that doesn't support deprecated features is called a forward compatible
context,
<https://www.opengl.org/discussion_boards/showthread.php/175052-Forward-compatible-vs-Core-profile>  

There appears to be an issue with OpenGL >3.0, but this is above my head.

IS anyone else using Dual Radeon RX 580?






-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

tangerine0469
MichaelAtOz wrote
> IS anyone else using Dual Radeon RX 580?

When I checked using taskman, nothing aside from the normal windows desktop
services. On a whim I opened the app and moved it to another monitor (Each
card has two displays plugged into them, arranged in an 1 over 3 array) and
closed it so windows remembered which one to render it on when opened
next... Turns out the moment I opened it on the primary display (last test)
suddenly it rendered just fine.

I took it and repeated the process on each monitor again and boom, works
like a charm now. Best guess here is that the one card crapped out/hiccuped
and being as windows persistence was in play it got caught in a loop until
moving it around the cards cleared it up. Still kinda like voodoo but I will
take it as a win.

Thank you for the help, prods in the right direction and trying to figure it
out. Seems like this experience will definitely be useful on a rainy day.




--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

MichaelAtOz
Administrator
That's good.


Are you getting 'WARNING: Object may not be a valid 2-manifold and may need
repair!'?
If so I suspect the

linear_extrude(ild,true) translate([-(ild * 1),-(ild * 21),ild])
        rotate([0,0,45]) square([fd,fd],true);

Is coplanar with the rest.

You should also see  this
<https://en.wikibooks.org/wiki/OpenSCAD_User_Manual/FAQ#What_are_those_strange_flickering_artifacts_in_the_preview?>  
re preview artifacts.

But i presume you are still working on it.



-----
Admin - email* me if you need anything, or if I've done something stupid...

* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

The TPP is no simple “trade agreement.”   Fight it! http://www.ourfairdeal.org/   time is running out!
--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Admin - email* me if you need anything,
or if I've done something stupid...
* click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work.
Obviously inclusion of works of previous authors is not included in the above.


The TPP is no simple “trade agreement.” Fight it! http://www.ourfairdeal.org/ time is running out!
Reply | Threaded
Open this post in threaded view
|

Re: Crash on F6 and missing preview/render window

kintel
Administrator
In reply to this post by tangerine0469
> On Sep 16, 2018, at 1:45 AM, tangerine0469 <[hidden email]> wrote:
>
> Thank you for the help, prods in the right direction and trying to figure it
> out. Seems like this experience will definitely be useful on a rainy day.
>
Btw., we have some similar issues registered on github:
https://github.com/openscad/openscad/issues/1522
https://github.com/openscad/openscad/issues/2046

 -Marius


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org