Best version of OpenSCAD (and OpenCSG) for Linux?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Best version of OpenSCAD (and OpenCSG) for Linux?

Gadgetmind
I'm using Ubuntu 16.04 and the version from the PPA is 2015.03, which
barfs on my list comprehensions (and tells me the wrong line number when
using include) so I want to use a later one.

On my Windows machine I use the nightly 2017.04.05 (git d22fa32) , which
works fine.

My Linux machine has 2017.06.03.nightly , which also work but I get
awful results with preview when objects are sliced on various planes. If
my viewing point moves to the other side of the plane, I see the wrong
bit of the object!

Is this likely to be down to the version of OpenSCAD or the version of
OpenCGS? Googling suggested some driver bugs were worked around in
OpenCSG 1.4.1 (I'm on 1.4.0) but these were for Intel and I'm using AMD
Radeon.

I'm really not sure what to try changing, where to get a newer OpenCSG,
or anything else I can fiddle with (I tried forcing GoldFeather.)

BTW, here is the list comprehension that fails. Am I relying on
unsupported syntax?

EngineWidths= [
     for (a = [0: $fa: 90]) [ (1-cos(a))*EngineR3, EngineFrontWidth -
(1-sin(a))*EngineR3] ,
     [EngineBandX1, EngineMaxWidth],
     [EngineBandX2, EngineMaxWidth],
     for (a = [0: 1: 90]) [ EngineLength -EngineR5 + sin(a)*EngineR5,
EngineRearWidth - (1-cos(a))*EngineR5]
];



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
Reply | Threaded
Open this post in threaded view
|

Re: Best version of OpenSCAD (and OpenCSG) for Linux?

codifies
for me (on Void Linux) I've had no problems compiling from github sources, seems to work just fine!

void linux packages version 1.4.2_1 of openSCG which I used to compile OpenSCAD with, while I have had
the odd assert error with openSCG but not enough of a show stopper to make me think it would be worth
compiling openSCG too.

I'd welcome OpenSCAD making a file release from current git every few months, the years old
version is the one that usually gets packaged and it shows OpenSCAD in a not particularly
good light...
 

On 17/07/17 12:47, Ian Oliver wrote:
I'm using Ubuntu 16.04 and the version from the PPA is 2015.03, which barfs on my list comprehensions (and tells me the wrong line number when using include) so I want to use a later one.

On my Windows machine I use the nightly 2017.04.05 (git d22fa32) , which works fine.

My Linux machine has 2017.06.03.nightly , which also work but I get awful results with preview when objects are sliced on various planes. If my viewing point moves to the other side of the plane, I see the wrong bit of the object!

Is this likely to be down to the version of OpenSCAD or the version of OpenCGS? Googling suggested some driver bugs were worked around in OpenCSG 1.4.1 (I'm on 1.4.0) but these were for Intel and I'm using AMD Radeon.

I'm really not sure what to try changing, where to get a newer OpenCSG, or anything else I can fiddle with (I tried forcing GoldFeather.)

BTW, here is the list comprehension that fails. Am I relying on unsupported syntax?

EngineWidths= [
    for (a = [0: $fa: 90]) [ (1-cos(a))*EngineR3, EngineFrontWidth - (1-sin(a))*EngineR3] ,
    [EngineBandX1, EngineMaxWidth],
    [EngineBandX2, EngineMaxWidth],
    for (a = [0: 1: 90]) [ EngineLength -EngineR5 + sin(a)*EngineR5, EngineRearWidth - (1-cos(a))*EngineR5]
];



_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org


_______________________________________________
OpenSCAD mailing list
[hidden email]
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org