2020.12-RC3 OpenSCAD.exe doesn't uninstantiate when exited - W7

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

2020.12-RC3 OpenSCAD.exe doesn't uninstantiate when exited - W7

drafter
This post was updated on .
Hello All,

Thanks for all the great OpenSCAD work!

I've been using older release versions since 2016, but now am using
2020.12-RC3 in Win7 Pro SVC Pk 1, DotNet V4.7.3062.0

Here's the problem. I instantiate OpenSCAD ver 2020.12-RC3, I do some work.
I Click the 'x' gadget in the upper right corner of the program Title-Bar to
Exit the program. I Exit the program, then later restart the program, do
some more work, exit, and then re-instantiate, exit, etc.  Shortly, after a
few of these start/exit cycles, windows begins to become very sluggish,
responsiveness becomes 'jumpy', mouse carrot doesn't keep up with movement,
etc.

In looking at the Windows Task Manager, I see that the OpenSCAD program is
not depicted in the "Applications" dialog as I did Exit the program, yet
there is an OpenSCAD.exe running for each instance where I started the
program, which are still running in 'background'. At times I may load and
exit the program four or five times durring a design, slice, print session.
Each instance leaves some part of the program running, eating up system
resources.

To be thorough, to Exit program I also tried,
Click File
   Click Close - which apparently closes the program, while leaving
something running in background as indicated in the Processes dialog of the
Windows Task Manager.

And also Clicking File > Quit and-or depressing ^Q, also exhibits the same
problem, eg., not killing the background OpenSCAD.exe process,

And then also, intermittently, the program not only does not Exit, but also,
reports "Program not responding" error message, and screen becomes
low-lighted, eg, 'loses focus' and the only strategy to close it is to kill
the process via the Task Manager.

Another issue that I've seen, concerns the IDE's editor "Find" function,
which intermittently can't find or misfinds text. One example I was
searching for the color "orange", the IDE stopped on Mot"or".

Here are a few images for y'all to gander at:

Task Manager Depicting OpenSCAD.exe via Application Dialog showing that "Application" is not running...

Task Manager Depicting OpenSCAD.exe via Application Dialog showing that "Application" is not running

Task Manager depicting OpenSCAD.exe running in background via "Processes" dialog when OpenSCAD
"Application" isn't running:

Task Manager Depicting OpenSCAD.exe via "Application" dialog showing that OpenSCAD "Application" is not running:

Another Task Manager capture, of THREE OpenSCAD.exe's "Processes" running as shown in the "Processes" dialog, yet there are no User Interfaces running in foreground.

 Another Task Manager capture, of THREE OpenSCAD.exe's "Processes" running, yet there are no User Interfaces running in foreground.


Hope this helps...

Thanks,

Drafter




--
Sent from: http://forum.openscad.org/

_______________________________________________
OpenSCAD mailing list
Discuss@lists.openscad.org
http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org